NextGEN Gallery
Changing to caption or carousel template (6 posts)

  1. David49
    Posted 5 years ago #

    Does the caption or carousel gallery work with the latest version of nextgen when a slideshow is set via a gallery using shutter. I have tried creating a nggallery folder in the default theme and copying the templates there and adding the template=caption to the page but nothing seems to happen. Would appreciate any help, thanks.


  2. Rhand
    Posted 5 years ago #

    Trying to run a custom NGG theme carousel as well and need captions too. Trying to load it is a custom field en so far now luck. What short tag are you using?

    This code:

    <?php /* NG Gallery Custom Field Rotating Images  */
        $gallery = get_post_meta($post->ID, 'gid', true);
        $gal = $gallery;
        $gal = apply_filters('the_content', '[gallery='.$gal.']' );
        echo $gal;

    Works, but as soon as I add template=resort images=7 it starts showing two thumbnails of which one is my Featured Image.

    [gallery=1 template=carousel] in the post text shows just two images of which one is my featured image as well. Maybe the template/theme interferes?

  3. David49
    Posted 5 years ago #

    Have tried your code Rhand but no joy

    using [nggallery id=1 template=carousel images=10]

    but get nothing other than the main image as a slideshow

    Still puzzled hoping someone can help

  4. Rhand
    Posted 5 years ago #

    See short tag here: http://nextgen-gallery.com/templates/carousel/ . It should work running the latest NextGen Gallery and a short tag code like nggallery id=2 template=carousel images=7 ] should work. That is the one I use in my custom field as well. Only difference is that I use a custom template now. So my template is called differently.

  5. Rhand
    Posted 5 years ago #

    Double post

  6. David49
    Posted 5 years ago #

    Yes Rhand have tried that and all possible variations but getting nowhere. Probably need step by step idiot instructions, will keep at it. thanks

  7. Rhand
    Posted 5 years ago #

    Well David, hope you work it out. Would reinstall plugin and try, check error logs and try different short tags to troubleshoot it all.

Topic Closed

This topic has been closed to new replies.

About this Plugin

  • NextGEN Gallery
  • Frequently Asked Questions
  • Support Threads
  • Reviews

About this Topic


No tags yet.