Support » Plugin: NextGEN Gallery - WordPress Gallery Plugin » [Plugin: NextGEN Gallery] Can't insert gallery

  • Resolved arsenic13

    (@arsenic13)


    For the past few days, it seems that I can not insert a table. When I am in the post editor, and click the insert gallery button, and then click the scroll down menu to choose a gallery, the scroll menu shows a loading circle forever. It does not load. I can still get my galleries working by typing the gallery code, but this is pretty inconvenient for my new writers. Help would be great!

Viewing 15 replies - 1 through 15 (of 63 total)
  • I have also experienced this error – and when / if it does bring the list up – I cannot scroll through all the gallery’s available – of 136 gallery’s the list will stop consistently at #86 with what appears to be an <HR> below it.

    Strange thing is – I can insert a single picture from them but not from the dedicated “insert” button. I can also hard code them – but – of course it is much easier with the dedicated button.

    I have the latest version installed – and did not experience this with the previous version.

    Please advise

    – Mike

    That is exactly how it is for me. I don’t even have that many galleries, i just get that loading icon next to the drop down menu. I’m sure it’s a faulty firmware, but it’s hard to tell my other writers the steps around it.

    Solve it! change from control panel to the configuration PHP 5.x

    betojaton;

    I can’t seem to find an option which allows configuring PHP settings, but the server settings within next-gen reports:

    # PHP Version : 5.2.14
    # PHP Safe Mode : Off
    # PHP Allow URL fopen : On
    # PHP Memory Limit : 32M
    # PHP Max Upload Size : 2M
    # PHP Max Post Size : 8M

    What am I missing?

    – Mike

    I have the same issue and am running php 5.2x

    the menus just spin and spin. anyone able to solve this? i should have backed up my db before upgrading this plugin.

    arsenic13

    (@arsenic13)

    Still need help with this.

    triple-5

    (@triple-5)

    I am having this same problem on only one of many websites we have designed.
    Everything works fine when using the short code, but when we use the widget in the page or post editor, it can’t seem to find the galleries. Dial just sits and spins. On this one site, i have almost 50 galleries. is this a potential problem? The others that are working correctly, have less than 10. there is one site where the widget is working correctly, but only lists about the 50 most recent galleries (400 total). I have reinstalled the plug-in on the site in question, nothing seems to work..

    What gives? Could use some ideas..

    arsenic13

    (@arsenic13)

    A fix is very much needed. I read somewhere this won’t be an issue once the next major firmware of wordpress releases, but I’d like a fix soon.

    triple-5

    (@triple-5)

    I was able to finally able to resolve the issue, but it took a bit of work. Involves working directly with the database in mPHPadmin, not for the weak of heart!
    With that said, her goes..
    Back-up your database! This is important!

    1) in myPHPadmin (or whatever database tool you use) export the wp_ngg_xxx tables (3 or 4)
    2) Deactivate and delete the plugin.
    3) activate the plugin
    4) import the exported gallery data

    That did the trick for me, but no guarantees.

    arsenic13

    (@arsenic13)

    Even with the new Gallery update, this is still broken..

    BobHtg

    (@bobhtg)

    I’m having the same problem. I enter the shortcode and get a 404 message. Strangely, previously existing galleries show up, but due to a recent file reorganization, they’re the wrong images. When I insert the correct file ID in the shortcode, I get a 404 message.

    Singlepics also aren’t showing up as images, just ugly white tabs. I’ve asked for help three times so far over the last 2 weeks and gotten no response.

    NexGen was wonderful before these 1.7 updates, but now I can’t use it. Last night I finally decided to try a workaround using the WP insert button and that at least gives me thumbnails. Not a satisfactory solution, but it’ll have to do. What on earth do I have to do in order to get some help?

    BobHtg

    (@bobhtg)

    Okay, the bit with the 404 is a WP issue, not NexGen. It’s all rolling into one big frustration, but I’ve at least managed to separate the one from the other.

    Galleries and singlepics/thumbnails/whatever you want to call them are a NexGen problem. No point talking about it anymore, though.

    frankjreda

    (@frankjreda)

    Having the same problem. I’m using WP PHP 5 and NGG 1.7.4.

    I tried dropping the ngg tables, deactivating the plugin and deleting the files. I reinstalled and recreated the galleries only to find it still isn’t working.

    Any help or ideas would sure be appreciated.

    freeomega

    (@freeomega)

    Hi,

    I also have the same issue. It seems that I can’t insert any albums/gallery/image anymore from the “nextgen picker (NextGen.desc)” as the drop down lists don’t get populated (the wheel spins for half a second and stops).

    Any clue?

    Thank you!

    Plesin

    (@plesin)

    Hi,

    I had the same problem. The list of galleries/albums/list are loaded via an ajax call, so I had a look and found out the ajax call is getting a 403 Forbidden response. ( you can see the ajax call and response with Firebug).

    The problem with my site is, that I don’t have the WP installed in the root directory but in a subdirectory like this:

    wordpress address (URL): “http://www.mysite.com/wp-mysite”
    site address (URL) : “http://www.mysite.com”

    And the ajax call is getting a domain via a WP function site_url(), which returns in my case “http://www.mysite.com/wp-mysite” and that’s causing the problem.

    I had to change it manually in wp-content>plugins>nextgen-gallery>admin>tinymce>window.php

    In this file there is initialization of the autocomplete like this:

    jQuery("#gallerytag").nggAutocomplete( {
         type: 'gallery',domain: "<?php echo site_url(); ?>/"
     });

    so I changed the php block “<?php echo site_url(); ?>/” for the correct domain:

    jQuery("#gallerytag").nggAutocomplete( {
         type: 'gallery',domain: "http://www.mysite.com"
     });

    Please note I had to do it for all three types: gallery, album and picture and this is only a quick fix for me, as I don’t have the time to look for a better solution. Once you reinstall or upgrade the plugin you’d have to do it again.

Viewing 15 replies - 1 through 15 (of 63 total)
  • The topic ‘[Plugin: NextGEN Gallery] Can't insert gallery’ is closed to new replies.