NextGEN Gallery
[resolved] Cannot add Gallery to Album (58 posts)

  1. ideafrog
    Posted 4 years ago #

    Upgraded to 1.7.2 and now can no longer drag gallery into an album. Have tried via multiple browsers on multiple systems - to no success. It is as if it is not a selectable nor draggable item.

    Have read another thread - is the ONLY solution a downgrade of the site (Monumental!)

    Please advise - This is a critical component for us!


  2. Ed
    Posted 4 years ago #

    We're having the same exact problem on WordPress 3.0.3.

  3. kymora
    Posted 4 years ago #

    I am having the same issue. I too am on 1.7.2

  4. kymora
    Posted 4 years ago #

    I am not upgraded to 3.0.3. yet (hope that helps)

  5. vault
    Posted 4 years ago #

    I am using WP 3.0.3 and the Nextgen Gallery Plugin in Version 1.7.2 and have exact the same problem.
    When I try to drag and drop the gallery to an album it´s just highlighted.
    I didn´t have these problems since the last update to 1.7.2, I saw other threads, but in different versions.

    Does anyone already has a fix for this problem (other than downgrading or reinstalling)?

    many thanks in advance

  6. jefflane510
    Posted 4 years ago #

    I'm having the same issue and have tried disabling all other plugins as mentioned in an earlier post. It didn't solve the problem, so I think I need to go back to 1.6.2. To this point I've only used the WordPress plugin finder/installer and never done it manually.

    Can anyone point me in the right direction for how to downgrade manually?


  7. Alex Rabe
    Posted 4 years ago #

    As often replied, it's a javascript conflict with other plugins. Try (just for a test) to disable other plugins and if it's then working , activate other plugins step by step

    If this doesn't help , check your browser if you receive any script error message

  8. kymora
    Posted 4 years ago #

    Alex - No that is not the case, at least with me. I haven't install anything since the update. I am not on 3.0.3 because of all the issues. I haven't changed anything except install your recent update and then the problems started. I cannot drop and drag, cannot minimize the albums. So I think that there is a problem with your update. Could you post how we can turn the clock back. That seems to be everyone's question. How do we downgrade to 1.6.2. until you figure out what it is that is conflicting. I have hundreds of albums I cannot afford to lose. I have read many posts where everyone has already uninstalled all their plugins with no luck.

  9. kymora
    Posted 4 years ago #

    Just to clarify I get no error code. Nothing actually happens.

  10. jefflane510
    Posted 4 years ago #

    I think I answered my own question on how to downgrade, but I didn't have hundreds of photos like kymora does. I was able to start from scratch again.

    I did try disabling ALL of the other plugins I had running, and I still couldn't get 1.7.2 to allow me to drag and drop galleries and albums.

  11. kymora
    Posted 4 years ago #

    So Jefflan501 - what did you do - uninstall and then reinstall 1.6.2.? What a nightmare! I love this product but it has rendered my bridal business on hold for 2 days now. I have commitments and need to get this fixed. If anyone can tell me how to save my work and downgrade I would so appreciate your help.

  12. kymora
    Posted 4 years ago #

    My apologies to Alex - one of my interns installed Use Google Libraries in hopes to fix another issue we had. I deactivated it and now the software upgrade 1.7.2. works. Sorry again Alex.

  13. Alex Rabe
    Posted 4 years ago #

    FYI : In 1.7.X a new feature (http://alexrabe.de/2010/12/02/scalability/ ) require a new script library (jQuery 1.8.X). If a other plugin didn't handle the script intergration correct, then a conflict happend. You have three options in this case :

    1. Stay on 1.6.x ( http://wordpress.org/extend/plugins/nextgen-gallery/download/ )
    2. Wait until WordPress 3.1 release ( it comes with the latest script version and will solve the conflict)
    3. Disable other plugins which maybe cause the conflict

    If drag&drop didn't work it MUST be throw a script error, so watch out for an error in your browser, and report back if you have questions

  14. tdkibbee
    Posted 4 years ago #


    I have no other plug-ins installed (never have). I get the following Javascript error:

    Message: 'a.widget.prototype._trigger' is null or not an object
    Line: 53
    Char: 22651
    Code: 0
    URI: http://mysite.com/wp-admin/load-scripts.php?c=1&load=jquery-ui-core,jquery-ui-draggable,jquery-ui-droppable,jquery-ui-sortable,jquery-ui-tabs,hoverIntent,common,jquery-color&ver=21b4e39b28942c7720b23d0910a2934b

    Is my only option to downgrade? Or is it possible to manually update the database to create the albums?


  15. tdkibbee
    Posted 4 years ago #

    Follow-up to my last post, I am using a theme from Obox Design, is that the possible conflict?

  16. Alex Rabe
    Posted 4 years ago #

    Yes, themes could also inject Javascript in a wrong way, test the behaviour with the default theme

  17. ruizwashere
    Posted 4 years ago #

    I had the exact same problem. Disabling the "WP-PhotoNav" plugin I had installed did the trick.

    Thanks so much for the advice Alex.

  18. tdkibbee
    Posted 4 years ago #

    Is it possible update the album/galleries via the database? I don't really care about the drag and drop functionality if I can just create the album at the DB level.

  19. angler2010
    Posted 4 years ago #

    Has anyone had any luck with getting the galleries into the album.

    Seems to be something to do with the coding to me though I am just a leaarner

    I would really like to get this thing working unless someone knows of a better plugin to use.

  20. kymora
    Posted 4 years ago #

    I had this problem and it's a pluggin. For me it was Google Library. Anything you have installed that is helping you support javascript is probably the culprit. Alex is right if you look at the bottom left of your web browser while you load your home page it will tell you where the error is. Then click VIEW, SOURCE on the menu bar and now your source code should pop up in a separate window. Find the line that the error code is on - now look and see what plugin it's using. That's the one you deactivate. Hope this helps - I know how frustering it is!!

  21. angler2010
    Posted 4 years ago #


    Thanks for the idea. I tried and saw nothing obvious. Once I think I saw javascript void () or something like that. It didn't stay long before going into the ether.

    widgets I use are

    nextgen gallery
    Widget logic
    Fluency admin

    I think the last one only affects the dashboard, not that I would really know.

    site http://www.obrienboats.com.au

  22. angler2010
    Posted 4 years ago #


    I tried on both my XP PC and my Mac with the same result.
    Still can't drag or drop or put the gallery into the album.
    The album is there, the gallery's are there they just don't want to get mixed up with each other.

    I am assuming one drags the gallery to the left into the blank space below the album name.
    Not much in the way of instruction there.

    Great plugin, pity it doesn't work.

  23. kymora
    Posted 4 years ago #


    I am just taking a stab at this but in your source code you have something called wp-photo-album plus. If that is a stand alone plugin try removing that. To answer you other question yes you first have to make an album (there is a box you type in the name of your album to creat it)and then you drop and drag the gallery over to the left. If you already have an album created in the far right column - select it from the drop down box and then drag the gallery over to it. Good luck! I hope the update comes soon.

  24. angler2010
    Posted 4 years ago #


    Yes I put that one in after the nextgen album failed to work. That one also has some problems as it wants to put the album into a column (probably side bar 1)that does not exist in my site. The theme has up to three columns and I use only the content column and sidebar two as the RHS sidebar column. wp-photo-album puts its pictures well on the left hand side and totally destroys the whole page. The instructions have been followed to the letter so It's not me.
    I am deleting that one today.

    I will keep my fingers crossed for the update. Until then I will just make the existing gallery much larger.
    I am doing exactly as you suggested for the nextgen album still with no success. One would think if a facility doesn't work just delete it until it does. That's what beta testing is all about. Judging by the various forums many users are having problems, we are not all experts. Everyone is a learner till we die.

    Thank you very much for the answers and suggestions.
    I still love the easy gallery in nextgen. Dead simple!!

  25. TuneDelete
    Posted 4 years ago #

    I am dealing with the same problem.

    What happens If I delete the Nextgen Gallery Plugin to reinstall an earlier version?

    I will delete it from the Plugin section... It gives a warning that it will delete all files and data related to this plugin. Is it also deleting all my gallery's with photo's? That's not my intention actually ;)

    Thanks in advance.

  26. angler2010
    Posted 4 years ago #


    That would be a major problem, particularly for people with large galleries such as photographers.

    It is clear that the album function is not working so we will have to wait until either the plugin is updated or wordpress sort out the problem.

    If I was 30 years younger I could even help. Brain is going dead, so sad too bad, age catches up to all of us.


  27. TuneDelete
    Posted 4 years ago #

    @ angler2010,

    I have looked up in the ftp directories but I found the gallery's in another section than the plugin section.

    I have read in earlier posts that it is possible to 'downgrade' the plugin and install an earlier version of nextgen-gallery. But I cannot install an earlier version right in WordPress. I have installed the setup, unrarred it, then uploaded it with FTP client into the plugin directory but now I cannot see it in the plugin section in the WordPress Dashboard.

    Any solutions to downgrade?

    Thanks in advance,

  28. giles14
    Posted 4 years ago #

    Hi there,

    I have found a solution (at least for my case): Update the jQuery UI library on WordPress Core.

    IMPORTANT: If you want to try this, be sure to backup any file used here.
    This is only a quick-fix the complete solution will be release at WordPress 3.1.
    Use this solution at you own risk.
    Pack: http://bit.ly/eAp34K
    Files included in the pack:

    Download 1.8.7 UI Pack:
    unpack it.
    Replace the files (trough FTP) in yoursite/wp-includes/js/jQuery/ with those included in the pack. *Backup your files.

    Go to: yoursite/wp-includes/
    Download and backup script-loader.php:
    Open it with your favorite editor (dreamweaver, Notepad etc.) and look for this lines:

    $scripts->add( 'jquery-ui-core', '/wp-includes/js/jquery/ui.core.js', array('jquery'), '1.7.3' );
    	$scripts->add_data( 'jquery-ui-core', 'group', 1 );
    	$scripts->add( 'jquery-ui-tabs', '/wp-includes/js/jquery/ui.tabs.js', array('jquery-ui-core'), '1.7.3' );
    	$scripts->add_data( 'jquery-ui-tabs', 'group', 1 );
    	$scripts->add( 'jquery-ui-sortable', '/wp-includes/js/jquery/ui.sortable.js', array('jquery-ui-core'), '1.7.3' );
    	$scripts->add_data( 'jquery-ui-sortable', 'group', 1 );
    	$scripts->add( 'jquery-ui-draggable', '/wp-includes/js/jquery/ui.draggable.js', array('jquery-ui-core'), '1.7.3' );
    	$scripts->add_data( 'jquery-ui-draggable', 'group', 1 );
    	$scripts->add( 'jquery-ui-droppable', '/wp-includes/js/jquery/ui.droppable.js', array('jquery-ui-core'), '1.7.3' );
    	$scripts->add_data( 'jquery-ui-droppable', 'group', 1 );
    	$scripts->add( 'jquery-ui-selectable', '/wp-includes/js/jquery/ui.selectable.js', array('jquery-ui-core'), '1.7.3' );
    	$scripts->add_data( 'jquery-ui-selectable', 'group', 1 );
    	$scripts->add( 'jquery-ui-resizable', '/wp-includes/js/jquery/ui.resizable.js', array('jquery-ui-core'), '1.7.3' );
    	$scripts->add_data( 'jquery-ui-resizable', 'group', 1 );
    	$scripts->add( 'jquery-ui-dialog', '/wp-includes/js/jquery/ui.dialog.js', array('jquery-ui-resizable', 'jquery-ui-draggable'), '1.7.3' );
    	$scripts->add_data( 'jquery-ui-dialog', 'group', 1 );

    Reaplace all '1.7.3' with '1.8.7'.

    Save the file and upload it to your server (to the same path).

    Done, now you can add galleries to albums.

    I hope this fix your problem.

  29. ekim501
    Posted 4 years ago #

    Awesome thanks – that worked for me to.

  30. angler2010
    Posted 4 years ago #


    Mate you are a legend. works just fine. Bit of a much around and a worry as well however I backed up all the items first then did the mods.
    My script calls look different probably cause I use 3.0.3 however look for '1.7.3' with your editor in lieu of the ;1.7.3& in your explanation.

    Now it works perfectly.

    Thank you very much.

Topic Closed

This topic has been closed to new replies.

About this Plugin

  • NextGEN Gallery
  • Frequently Asked Questions
  • Support Threads
  • Reviews

About this Topic


No tags yet.