WordPress.org

Support

Support » Plugins and Hacks » NextGEN Gallery - WordPress Gallery Plugin » [Plugin: NextGEN Gallery] Bad coding issues

[Plugin: NextGEN Gallery] Bad coding issues

  • I would be relieved if NextGen team finally fixes the myriad “standards compliance” issues such as (to name a few):

    — Redefining already defined constructor for class nggNavigation (navigation.php: 50)

    — call_user_func_array() expects parameter 1 to be a valid callback, non-static method nggGallery::nextgen_version() should not be called statically (plugin.php: 405)

    — Redefining already defined constructor for class nggdb in wp-content/plugins/nextgen-gallery/lib/ngg-db.php on line 60

    — Redefining already defined constructor for class nggPostThumbnail in wp-content/plugins/nextgen-gallery/lib/post-thumbnail.php on line 26

    — Redefining already defined constructor for class nggNavigation in /wp-content/plugins/nextgen-gallery/lib/navigation.php on line 50

    — call_user_func_array() expects parameter 1 to be a valid callback, non-static method nggGallery::nextgen_version() should not be called statically in /wp-includes/plugin.php on line 405

    PS: NGG version is 1.9.3

    Chris.

    http://wordpress.org/extend/plugins/nextgen-gallery/

  • The topic ‘[Plugin: NextGEN Gallery] Bad coding issues’ is closed to new replies.
Skip to toolbar