WordPress.org

Support

Support » Plugins and Hacks » [Plugin: NextGen Gallery 1.5.5] [BUG] deprecated is_site_admin function

[Plugin: NextGen Gallery 1.5.5] [BUG] deprecated is_site_admin function

  • NextGen Gallery v1.5.5 contains three instances of the deprecated function is_site_admin(), which are reported when using WP_DEBUG = true in wp-config.php

    is_site_admin was deprecated in WP 3.0 and replaced with is_super_admin

    nextgen-gallery/admin/admin.php
    change is_site_admin to is_super_admin (2 instances)

    function wpmu_site_admin() {
    	// Check for site admin
    	if ( function_exists('is_site_admin') )
    		if ( is_site_admin() )
    			return true;
    
    	return false;
    }

    nextgen-gallery/admin/wpmu.php
    change is_site_admin to is_super_admin (1 instance)

    //to be sure
    	if (!is_site_admin())

    It’s possible but not sure these are also responsible for a “headers already sent error” occurring at the same time after uploadng an image and using its URL as the image location for a sidebar widget blogroll image …. still testing that one.

Viewing 1 replies (of 1 total)
Viewing 1 replies (of 1 total)
  • The topic ‘[Plugin: NextGen Gallery 1.5.5] [BUG] deprecated is_site_admin function’ is closed to new replies.
Skip to toolbar