WordPress.org

Support

Support » Plugins and Hacks » [Resolved] [Plugin: NewStatPress] NewStatPress/Details/Map not showing visits

[Resolved] [Plugin: NewStatPress] NewStatPress/Details/Map not showing visits

  • CockpitSeeker

    @cockpitseeker

    Hi,
    I figured only now that the map displaying country visits’ proportion no longer “redden” anything on it.

    I can’t tell if this feature broke:

    • due to the change StatPress vs NewStatPress or
    • due to the latest update of wordpress that I applied only recently…

    …as I didn’t check the “Details” tab before with NewStatPress.

    Any clue on what happened? Did that happen to anyone else/is that a known issue?

    Cheers

    http://wordpress.org/extend/plugins/newstatpress/

Viewing 12 replies - 1 through 12 (of 12 total)
  • Plugin Author ice00

    @ice00

    No other people have this specific problem.

    However, the render is done by a Google api call, so somethimes there can be a problem in Google free service itself.

    This features is the same of StatPress as this part of code is not changed until now

    CockpitSeeker

    @cockpitseeker

    Got it! Indeed I’m having issues with my Google APIs, other programs are misbehaving because of that.
    Disregard this thread, problem “solved”!

    Using WordPress 3.3.2, and Newstatpress version Version 0.3.8 which I recently performed an update.

    For some reason I show stats for June 8th 2012 but NO stats for June 9th 2012 through June 12th 2012. So basically 4 day’s are not showing up. I tried a database repair and optimize and this did not fix this display.

    It seems that there some links broken in the database or somehow the number are just gone.

    Is there a way to diagnose and repair this?

    This is my issue and effecting all websites:

    ## System particulars ##
    OS WIN64
    Apache 2.2.22
    PHP 5.3.4
    Wordpress = latest
    Plugin = latest
    ################

    Visits show exactly 1 visit per day. Today is 1 and yesterday was 1. The stats for pageviews, spiders, and feeds are all correctly reporting. This problem began about 5 days ago.

    I have tried deleting the plugin and manually removing the statpress tables from the MYSQL databases. Then reinstalling. This does not help and visits are persistently reported as exactly “1” each day.

    Any and all help will be appreciated.

    Follow up: Here is something I just noticed.

    These are errors produced when using the plugin’s update option.

    WordPress database error: [Duplicate key name ‘spider_nation’]
    ALTER TABLE wp_statpress ADD index spider_nation (spider, nation)

    WordPress database error: [Duplicate key name ‘ip_date’]
    ALTER TABLE wp_statpress ADD index ip_date (ip, date)

    WordPress database error: [Duplicate key name ‘agent’]
    ALTER TABLE wp_statpress ADD index agent (agent)

    WordPress database error: [Duplicate key name ‘search’]
    ALTER TABLE wp_statpress ADD index search (search)

    WordPress database error: [Duplicate key name ‘referrer’]
    ALTER TABLE wp_statpress ADD index referrer (referrer)

    WordPress database error: [Duplicate key name ‘feed_spider_os’]
    ALTER TABLE wp_statpress ADD index feed_spider_os (feed, spider, os)

    WordPress database error: [Duplicate key name ‘os’]
    ALTER TABLE wp_statpress ADD index os (os)

    WordPress database error: [Duplicate key name ‘date_feed_spider’]
    ALTER TABLE wp_statpress ADD index date_feed_spider (date, feed, spider)

    WordPress database error: [Duplicate key name ‘feed_spider_browser’]
    ALTER TABLE wp_statpress ADD index feed_spider_browser (feed, spider, browser)

    WordPress database error: [Duplicate key name ‘browser’]
    ALTER TABLE wp_statpress ADD index browser (browser)

    Plugin Author ice00

    @ice00

    These are errors produced when using the plugin’s update option.

    WordPress database error: [Duplicate key name ‘spider_nation’]
    ALTER TABLE wp_statpress ADD index spider_nation (spider, nation)

    Those are not true erros, but just that index in DB can be created only one time and they are already up and running.

    Visits show exactly 1 visit per day. Today is 1 and yesterday was 1. The stats for pageviews, spiders, and feeds are all correctly reporting. This problem began about 5 days ago.

    I have tried deleting the plugin and manually removing the statpress tables from the MYSQL databases. Then reinstalling. This does not help and visits are persistently reported as exactly “1” each day.

    Data are saved inside the wp_statpress table. If you have myphpadmin, open the table and see if there is collected data ont that dates (in each rows there is the data of the record).

    Using WordPress 3.3.2, and Newstatpress version Version 0.3.8 which I recently performed an update.

    For some reason I show stats for June 8th 2012 but NO stats for June 9th 2012 through June 12th 2012. So basically 4 day’s are not showing up. I tried a database repair and optimize and this did not fix this display.

    Did the update finish correctly? (in some hosting, PHP scripts are blocked afer 15 seconds and if you have many collected data it can use more times).

    Look with phpmyadmin if there are data stored inside wp_statpress with that data.

    I know what the numbers should be for the dates in question, I screen shot daily.

    Can someone give me the sql script to lookup in the table so I can update the fields manually ?

    I would think I need to find the Year, then the month, then the day and I should technicall be able to write in a value. I would think?

    Regards,

    Plugin Author ice00

    @ice00

    Insert data by hands is not so easy because I don’t think you have all the informations the plugin collects (ip and url are essentials).

    however, this is the structure:

    id mediumint(9) NOT NULL AUTO_INCREMENT,
          date int(8),
          time time,
          ip varchar(15),
          urlrequested varchar(250),
          agent varchar(250),
          referrer varchar(250),
          search varchar(250),
          nation varchar(2),
          os varchar(30),
          browser varchar(32),
          searchengine varchar(16),
          spider varchar(32),
          feed varchar(8),
          user varchar(16),
          timestamp timestamp DEFAULT 0,

    date, time, ip and urlrequests are essentials, the others can be compiled by a newstatpress update task and timestamp is only for realtime statistics (e.g. number of users connected actually) so it can be left empty.

    My issue is resolved. It was not related to your script and was an error in my routers IP tables. Thank you! ­čÖé

    Merhaba benimde sorunum da Arkada┼č microguy ile ayn─▒ ─░statistiklerimde ziyaret├žiler hep 1 g├Âz├╝k├╝yor.Bunu nas─▒l d├╝zeltebilirim?

    esmi

    @esmi

    Forum Moderator

    These are English language forums. Please use English.

    Statistics from the same problem with mine, visitors I also always a Friend g├Âz├╝k├╝yor.Bunu microguy how to fix it?

Viewing 12 replies - 1 through 12 (of 12 total)
  • The topic ‘[Resolved] [Plugin: NewStatPress] NewStatPress/Details/Map not showing visits’ is closed to new replies.