Deprecated code (1 post)

  1. mindctrl
    Posted 3 years ago #

    This plugin uses code that has been deprecated since WP 2.0, and it also has a few other issues that show up when WordPress debugging is enabled. I've tested this in 3.3 and 3.2.1, and it shows up in both. After seeing it, I tested it on two fresh installations as well to ensure it wasn't some sort of plugin or theme conflict.

    I don't know what effect the Undefined index messages have, if any. I'm somewhat concerned about the plugin using code that was deprecated so long ago. Does this cause any errors? Is this going to be updated?

    Notice: Undefined index: na in /var/www/vhosts/domain.com/public_html/newsletter/wp-content/plugins/newsletter/plugin.php on line 488 
    Notice: Undefined index: editor in /var/www/vhosts/domain.com/public_html/newsletter/wp-content/plugins/newsletter/plugin-menu.inc.php on line 3 
    Notice: has_cap was called with an argument that is deprecated since version 2.0! Usage of user levels by plugins and themes is deprecated. Use roles and capabilities instead. in /var/www/vhosts/domain.com/public_html/newsletter/wp-includes/functions.php on line 3466 
    Notice: Undefined index: act in /var/www/vhosts/domain.com/public_html/newsletter/wp-content/plugins/newsletter/plugin.php on line 652 
    Notice: Undefined index: page in /var/www/vhosts/domain.com/public_html/newsletter/wp-content/plugins/newsletter/plugin.php on line 68


Topic Closed

This topic has been closed to new replies.

About this Plugin

  • Newsletter
  • Frequently Asked Questions
  • Support Threads
  • Reviews

About this Topic