Support » Plugin: Networks for WordPress » [Plugin: Networks for WordPress] New site setup directly form url works only on the first network do

  • Probably everyone knows, multisite allows to create a site when a user types non-existent alias. For example, if the main network domain is and in the network we haven’t such site as, but we’ll type it manually, the system will start registration procedure for site sub-1 in domain “”.

    Unfortunately, in “networks” environment such thing is possible only for the domain, which is definad as DOMAIN_CURRENT_SITE in wp-config. If, for example, in our networks we have a second network, which has a domain, for example, and we’ll try to type non-existent url, such as, then the system won’t start registration procedure on “” for subdomain “sub-1”, but it will try to set up a site like “sub-1domain-2org” on domain “”. So, the result site will have such URL: “”!

    I tried to remove DOMAIN_CURRENT_SITE from wp-config, and it helps for registration, but then any site won’t work with www at the beginning.

    Please think about this issue in the future release.

Viewing 4 replies - 1 through 4 (of 4 total)
  • Plugin Author David Dean


    Have you actually created more than one network? Can you verify that they exist in the sites table? There’s a function in wp-settings/ms-load.php called wpmu_current_site() that will strip a www prefix, but it looks like it only does so when there’s just one network.

    If this is happening with multiple networks defined, you should try editing that function and see if you can resolve the problem.

    Because this function is part of WP, it is unfortunately not something I could address with this plugin. But if you find a workaround and let me know, I’d be happy to include it in the documentation!

    ‘www’ is not a main problem. I mentioned that, because I found solution, but it breaks ‘www’.

    The main problem is, that automatic signup redirects always to the first site in networks – let say to the ‘’. So, if I try to type, the system will able me to create site ‘foo’ in the ‘’. But if I type something like ‘’ the system wont redirect me to the ‘foo’ in ‘’, but it will suggest me to create site called ‘foonetwork2com’ in the ‘’, so the final URL looks like ‘”. That’s strange and very frustrating.

    Plugin Author David Dean


    Does the problem you described in the second post happen even if DOMAIN_CURRENT_SITE constant is removed?

    After reading your first post, I thought that problem went away if you removed that constant.

    If I removed DOMAIN_CURRENT_SITE, sign up worked properly, but the www prefix stopped working.

Viewing 4 replies - 1 through 4 (of 4 total)
  • The topic ‘[Plugin: Networks for WordPress] New site setup directly form url works only on the first network do’ is closed to new replies.