Support » Plugin: Networks for WordPress » [Plugin: Networks for WordPress] Can't get Networks to work, problem with FAQ step 2.

  • Hello all. I am so far unsuccessful in getting Networks for WordPress to function as it should. I have it installed and configured as per instructions up to step to of the FAQ…

    Configure your web server to direct requests for each desired domain to the same site (e.g. via ServerAlias directives or Host Headers

    I have no idea how to do this or where to even begin. Actually I think I might have an idea that you need to modify the httpd.conf file but I’m told by my hosts (I’ve tried both HostGator and Network Solutions) that my package doesn’t allow access to that file and that I need VPS or dedicated server which is more money than I was wanting to pay.

    I have pointed my domains at my hosting IP and when I test the settings in the initial network set up all of the tests are passed. When I go to the domain I get a 404 error.

    I know I’m missing something but I don’t know what it is.

    Extra information, I have been able to successfully create a network of sites at the root domain after setting up wildcard DNS. (root, and subdomain sites,,
    Should Networks for WordPress work in the same way as this, as in when I create a new network is it as simple as clicking a few buttons on the WordPress dashboard?

Viewing 13 replies - 1 through 13 (of 13 total)
  • Plugin Author David Dean


    Hi, magichew,

    With DNS and the web server configured correctly, it should be very simple to provision a new network.

    You don’t necessarily need a VPS, but you will have to talk to your web host and confirm whether they allow you to point two domains at the same website. It sounds like you have set up DNS correctly, but your web server may not know how to handle the second domain — or it may be serving different files for that domain.

    Unfortunately, I am not familiar with HostGator or its management interface, so I don’t have any specific tips for you on how to accomplish this.

    Hi David

    Thanks for your reply.

    I’ve done more investigation and asked Hostgator directly about the httpd.conf file that my server is using and they have said that AllowOverride is as it should be.

    My concern now switches to my htaccess file which is exactly has it should as it was pulled directly from WP’s network setup process. As I’ve said I can successfully add and wiew subdomains sites on the root domain. I can add a new Network with my other domain and create a root site and have all of the checks pass but when I click any links from the dashboard to take me to that site (or its dashboard) I get a Hostgator 404 page which again reinforces my believe that the DNS is set right but maybe there’s something going wrong in my .htaccess file.

    One thing perhaps worth noting is the Networks menu where it shows the list of Networks if I hover over the network that will not work and click Verify the very last check on the next page (“Checking DNS for hosted site subdomains:”) doesn’t get a green pass mark like the rest. It doesn’t get anything below it.

    Any help on this one would be much appreciated as this plugin is exactly what I’ve been looking for for a long time!

    Plugin Author David Dean


    It sounds like a DocumentRoot problem. Both domains need the same document root.

    I’m thinking an easy way to troubleshoot this is to make a simple test page, call it “test.html” or something. Put something distinctive in it. Upload it to your WordPress directory. Then see whether you can get to that file with both domain names.

    When you can access that file at the same path (say, “/test.html”) with both domains, the server is set correctly. Let me know if you have any more questions!

    And thanks for reporting the issue with the verification. I’ll check on that and see if I can figure out why it’s just blank for you.

    David, thanks again for your reply.

    I’ve progressed a little. Firstly I’ve taken the step of having my domains and hosting all coming from Network Solutions. By that I mean I’ve bought hosting and two domains from NS. This seems to have solved part of the issue in that I can not successfully visit a new network at a different domain.

    I still have issues with sites at subdomains on both the root site and the new network on the different domain.

    I’ve tried the html file trick that you have suggested and I can go to both domains/test.html and see the file. Interestingly the second domain adds www. to the beginning of the web address. I type, and it comes up with
    This doesn’t happen with my root domain.

    Could this be a factor?

    Thanks again for your help, I didn’t realise I was submitting a bug report earlier when I mentioned the verification, I just assumed there was something funky with my set up. If I’ve helped in some way then I’m really pleased.

    Plugin Author David Dean


    That could absolutely be a factor. Did you create your new Network at “” or at “”? If it’s the latter, the redirect to “www.” is going to keep your Network from working.

    From your first post, I thought sites on your first domain were working. Has that changed? Or maybe I just misunderstood.

    This gets stranger. Now both domain test.html files show up fine if I go to www. or not.

    Stranger still, I have one sub domain site working on my root site but subsequent ones give me the same 404 error that I get on all of the subdomains for my second domain.

    Reading my first post I can see that I once had the ability to create sites at will at my root domain. That was when I was using my Hostgstor hosting and had my Network Solutions domains pointing there. At of the other domains that is set up with NS and pointed there passed all of the verify tests but visiting the dashboard or the site got a 404.

    Im going to try a complete uninstall of everything and start again to see if that achieves anything.
    I’ll clear everything from my FTP account and drop all tables from my database, reupload WordPress and run the install.

    Is that enough to achieve “factory settings”?

    I’ve just done a completely fresh install of WordPress, activated multisite and create a new site on a subdomain. All is well, is working! Eureka I thought! Not so. Created a second test site and I get the same 404 that I’ve been getting all along.

    So I thought I’d try installing Networks for WordPress and see how things went…

    New network sets up find and I can visit the root site for that network,, returns that 404.

    Why would I be able to get one extra site on my network but then no more?

    Don’t know if this is any good but I once again made a fresh install and first thing I did was change my permalinks as I’d been reading that this could be an issue.

    Changed permalinks and everything broke, Forbidden, You don’t have permission to access /********/htdocs/wp-admin/options-permalink.php on this server.

    644 on .htaccess sorted that.

    Perhaps that has been an issue because now when I’m setting up multi site I get a message at the top about wildcard DNS. But I’ve checked my DNS settings and there’s a * A record there.

    Okay. Another development. I have realised that Network Solutions, my host and registrar do not support Wild Card DNS. The reason that I can get working is because at some point through my testing I have manually entered that address into my settings.

    So my question is, is Wild Card DNS a registrar or hosting issue?

    Time to search for another host/registrar?

    Have you tried to simply manually park the domains / subdomains instead of using the wildcarding? We’ve done this successfully on Hostgator for a regular multisite network.

    I’m actually looking here to solve a myriad of odd behavior with the Networks for WordPress plugin but I’ll post that separately!

    Yeah, that works but isn’t what I want. I want the end user to be able to add sites of their own without me having to set them up manually.

    Plugin Author David Dean


    @magichew: Wildcard DNS is a DNS hosting issue. You can probably have DNS hosted by either your registrar or your web host.

    If you can’t get a wildcard record created, you won’t be able to get the automatic setup you’re looking for.

Viewing 13 replies - 1 through 13 (of 13 total)
  • The topic ‘[Plugin: Networks for WordPress] Can't get Networks to work, problem with FAQ step 2.’ is closed to new replies.