Network Latest Posts
[resolved] problem thumbnails (5 posts)

  1. Jenny Beaumont
    Posted 4 years ago #


    This is an awesome plugin! Have been looking for something as flexible as this for a long time.

    I do have one small hangup - the path for the thumbnails isn't correct. Somehow in this line:
    $thumbcode = str_replace( $current_blog->domain . $current_blog->path, $blogdetails->domain . $blogdetails->path, get_the_post_thumbnail( $post_id, $size, $attrs ) );
    the current blog is published twice, giving me a src path for the image that looks something like this:
    I've tried commenting out the second path name, but the url is then missing a / - can't seem to work it out.

    thanks for your help!


  2. Jenny Beaumont
    Posted 4 years ago #

    (missing .com in the address example is just a typo :) )

  3. Jenny Beaumont
    Posted 4 years ago #

    hmmm, ok, this finally worked for me:

    $thumbcode = str_replace( $current_blog->domain /*. $current_blog->path*/, $blogdetails->domain /*. $blogdetails->path*/, get_the_post_thumbnail( $post_id, $size, $attrs ) );

  4. Jose Luis SAYAGO
    Plugin Author

    Posted 4 years ago #

    Hello Jenny I'm glad you found the solution, it's pretty weird because as you can see here: http://8elite.com/blog/2012/03/14/network-latest-posts-examples/ they work perfectly, maybe it's something related to the way your blogs are created but I couldn't say, wish I could reproduce this behavior. I'll test your solution to see if everything keeps working as it does right now, if so I'll add this as a patch, so you don't have to hack the code each time you update the plugin.

    Kind regards.

  5. Jenny Beaumont
    Posted 4 years ago #

    Heya - thanks for responding. I notice in your site that the URLs actually start wp/content/, rather than the full on http://...just realized that I use a plugin to strip out the /blog/ from the URL - maybe that has something to do with it? In any case, my images show up great with those bits commented out :)

    now if I could just figure out how to target taxonomy - man joining those tables up are giving me major grief!

    ps : and thnx again for the great plugin :)

Topic Closed

This topic has been closed to new replies.

About this Plugin

  • Network Latest Posts
  • Frequently Asked Questions
  • Support Threads
  • Reviews

About this Topic