Support » Plugin: NetBlog » [Plugin: NetBlog] Netblog widgets not working

  • Hi,

    It appears that I’m having another issue with Netblog. For some reason, the widgets are not working at all. I have tried disabling all other plugins, in case there was a conflict somewhere, but they still did not work. Neither “Further Reading” nor “Referenced By” appear anywhere, no matter where I place them.

    A potentially related problem that I’m also having is that the “Further Reading” search box does not display any external results, only links that are local to my site.

    Am I the only person experiencing these issues? It is a fairly fresh installation of WordPress, I just installed Netblog, two more plugins, and barely have any posts on it yet. Not quite sure if I’m doing something wrong…


Viewing 8 replies - 1 through 8 (of 8 total)
  • Plugin Author Benjamin Sommer



    Netblog once used a Websearch API (Yahoo), but they turned their service down some time ago. (It’s a commercial API, like Google Websearch). By directly entering a URL (http://… or ftp://… or https://…), you can still enter web urls (see this as a temporary workaround).

    As for the widgets, I am going to have a look what might cause this problem.

    Amazing how much WordPress’s API has been changed from 3.3 to 3.4. I hope they are going to make their changes more transparent for plugin developers.

    Plugin Author Benjamin Sommer


    The widgets are showing up in WordPress 3.4.1 with its default theme.

    I am not using a stock theme. Is there anything you would recommend I do to narrow down the issue of why the theme I am using is not compatible with the widgets. I placed the widget in a “block” of it’s own – it does not output any html at all.

    Or perhaps there is some condition for output in your module that my theme is not satisfying? If it matters any, I am using the Warp Theme Framework.

    Thanks again!

    I activated the default theme and they still did not show up. Not sure if the Warp Framework irreversibly ruins their function…

    Plugin Author Benjamin Sommer


    If they don’t show up either in the sidebar or in one of the footer, then there must an incompatibility with another plugin. Try disabling all other plugins.

    The 2.18 update seems to have fixed this problem, thank you!

    Unfortunately, another problem has cropped up. Captions no longer display in posts. The shortcode is simply removed and there is no entry at all. When I go to the Netblog “captions” page in the admin panel, the following shows up:

    Warning: implode() [function.implode]: Invalid arguments passed in /xxx/wp-content/plugins/netblog/core/nbCaptionGUI.php on line 52

    Warning: implode() [function.implode]: Invalid arguments passed in /xxx/wp-content/plugins/netblog/core/nbCaptionGUI.php on line 78

    Here is a photo of what it looks like:

    Plugin Author Benjamin Sommer



    However, I am going to remove this feature in a future version. Caption capabilities in webpages turned out to be rather impractical. (There are more important things for webpages than caption numbering, since webpages tend to be much shorter than documents).

    Plugin Author Benjamin Sommer


    I just tried this “Warp Framework” and the widgets Further Reading and Referenced By are displayed, however, the overall appearance of this theme looks pretty strange (base theme).

    Anyway, I do not provide support for commercial plugins or themes (i.e. conflict resolution).

Viewing 8 replies - 1 through 8 (of 8 total)
  • The topic ‘[Plugin: NetBlog] Netblog widgets not working’ is closed to new replies.