Support » Plugin: Nav Menu Roles » [Plugin: Nav Menu Roles] Display mode & access role didn't show up

  • Resolved azri79

    (@azri79)


    Hi Kathy,

    I have installed it several time using wordpress repo and github but the extra fields (display mode & access role) didn’t show up.

    Look at screen options – advance menu properties, there is none.

    For your info, I using eMember on rockettheme – Tachyon. Please assist me. Thanks..

    http://wordpress.org/extend/plugins/nav-menu-roles/

Viewing 6 replies - 1 through 6 (of 6 total)
  • Plugin Author helgatheviking

    (@helgatheviking)

    Can you try switching themes and deactivating all plugins? It is probably a conflict with someone else’s code.

    Plugin Author helgatheviking

    (@helgatheviking)

    Please check out the 1.2 update. It uses an alternative method of restricting the menu items and will no longer conflict with a theme or plugin’s custom nav Walker.

    Thank you Kathy..

    Installed 1.2 update, but the real problem is with gantry framework i guess.

    Plugin Author helgatheviking

    (@helgatheviking)

    Is your framework adding other custom fields to the menu items on the admin side? Unfortunately WP doesn’t offer more hooks in that area, so I pretty much nuke everything to replace the menu options with my version. I’ve asked WP via trac to add hooks here, but it will probably be a while.

    Sorry the update doesn’t help you. It fixes potential conflicts on the front-end, but I guess the possibility is still there for conflicts on the backend.

    Yes there are 7 custom fields.

    What i did was set the pages to private, so the sub and sub-sub menus are hide.

    Plugin Author helgatheviking

    (@helgatheviking)

    Ahhh…. oh well. Glad you found a work around as there isn’t anything I can do until WP adds some hooks. That way Gentry and my plugin can both hook into the menu admin without wiping the other out.

Viewing 6 replies - 1 through 6 (of 6 total)
  • The topic ‘[Plugin: Nav Menu Roles] Display mode & access role didn't show up’ is closed to new replies.