Support » Plugin: Email Address Encoder » Plugin “Name in URL” Problem

  • Resolved netzgestaltung

    (@netzgestaltung)


    Hi there,

    when i configure the plugin “All In One WP Security & Firewall” there is a firewall option “DENY BAD QUERY STRINGS” and in there is an “encode” entry.

    So when activating this option the settings page the functionality of your plugin is broken.

    i can work arround by copying the htaccess result into the custom rules part and remove “encoder” from the list and deactivating the rule.

    But i think it may causes lesser security then and is not update able, which leaves me to think about removing your plugin.

    that said, the only solution i can imagine is to remove the string “encoder” from the URLs and requests of your plugin.

    The page I need help with: [log in to see the link]

Viewing 4 replies - 1 through 4 (of 4 total)
  • Plugin Author Till Krüss

    (@tillkruess)

    I’ve looked into this, unfortunately the plugin slug itself is email-address-encoder and that’s why activating the plugin triggers AIOWSF 😐

    However encode was remove from all urls, so it should only trigger once during activation.

    Thread Starter netzgestaltung

    (@netzgestaltung)

    thanks for that!

    maybe if you ask on their support forum, they have other ideas what to do (also for other plugin authors)

    kind regards
    tom

    Thread Starter netzgestaltung

    (@netzgestaltung)

    When i search for “encoder” in the wp-plugins directory i get 2 pages of results.

    Maybe a whitelisting for the specific plugin names would be an option (on AIOWPS side).

    https://wordpress.org/plugins/search/encoder/

    Plugin Author Till Krüss

    (@tillkruess)

    I did ask them about a year ago, they didn’t seem to care. You’re welcome to open another topic and I’ll chime in 👍🏻

Viewing 4 replies - 1 through 4 (of 4 total)
  • The topic ‘Plugin “Name in URL” Problem’ is closed to new replies.