Support » Plugins and Hacks » My Calendar » [Resolved] [Plugin: My Calendar] Missing Style Sheet

[Resolved] [Plugin: My Calendar] Missing Style Sheet

  • I upgraded to 1.9.1 and something isn’t working right. I updated all the JavaScript and styles back to the defaults, but on all pages but the homepage I’m getting nothing for the actualy stylesheet name.

    URL: http://www.freundshippress.com/events/

    This is what is displayed:
    <link rel="stylesheet" href="http://www.freundshippress.com/wp-content/plugins/my-calendar/styles/" type="text/css" media="all" />

    …which obviously causes some pretty severe layout problems. If I manually throw the styles in the header it looks better but the JavaScript isn’t being loaded so nothing works. I’ve double checked that the “only load on certain pages” boxes are all empty.


Viewing 7 replies - 1 through 7 (of 7 total)
  • Plugin Author Joe Dolson


    Have you visited your style editor page and verified that you have a stylesheet selected, and that the selected stylesheet exists? Are you using one of My Calendar’s styles, or your own custom stylesheet?

    I am using the default stylesheet, and as you can see, it works on the homepage: http://www.freundshippress.com/ – just doesn’t load on any of the inside pages.

    Plugin Author Joe Dolson


    All right — that’s interesting. Does your theme have multiple header files? It sounds rather like the inside pages aren’t calling wp_head, although that would be a fairly unusual setup for a theme.

    Plugin Author Joe Dolson


    Wait, sorry – that’s not quite right, clearly wp_head is being called, just not getting the value. That’s even stranger…I’ll have to give this some thought.

    It’s a Twenty-Eleven child theme. If you want to send me an email at web (at) sparkweb dot [net] I can email you the theme files if that would be helpful.

    Joe, another update: and it really doesn’t make any sense.

    I tried disabling some plugins and found that when I disabled my plugin, FoxyShop, the stylesheet shows up correctly. I did all this troubleshooting and looking through your code to figure out what might be going on and then realized that after turning my plugin back on, everything was still working.

    Doesn’t really make any sense, but now it is showing up properly, after disabling FoxyShop and re-enabling it. So apparently it’s all fixed. Very, very strange and one of those things…..

    Thanks for your responsiveness, it’s much appreciated.

    Plugin Author Joe Dolson


    Well. Yep, I’m with you on th weirdness of this. I’m glad that it’s all resolved now, at least.

Viewing 7 replies - 1 through 7 (of 7 total)
  • The topic ‘[Resolved] [Plugin: My Calendar] Missing Style Sheet’ is closed to new replies.
Skip to toolbar