Multisite Robots.txt Manager
[resolved] Problem with plugin activation (6 posts)

  1. -SolidSnake-
    Posted 4 years ago #

    in my wordpress user i've administrator permissions.
    After installation, i can't activate the plugin with the button "activate" because appears this message:

    This plugin can only be activated and accessed through the Newtork Admin.

    When i try to uninstall the plugin, i receive this message response:

    Fatal error: Call to undefined function switch_to_blog() in /web/htdocs/MY_DOMAIN/home/wp-content/plugins/multisite-robotstxt-manager/uninstall.php on line 32

    How can i have these problems?
    Thank you!


  2. tribalNerd
    Plugin Author

    Posted 4 years ago #

    Hello -SolidSnake-,
    The Multisite Robots.txt Manager can only be activated on WordPress Installs using the Multisite Network feature. This would be why you're getting the first error.

    With the uninstall issue: I'm unable to replicate the uninstall error on my end, however I can understand why it would create that error. The function switch_to_blog() is a built in WordPress function for Multisite Networks, thus if your setup is not MS Network Activated then it wouldn't have that function.

    I will correct this... however that does not correct the issue for you.

    You will need to manually delete the plugin via ftp. It can be found within /wp-content/plugins/ms-robotstxt-manager - You can delete the folder or just the uninstall.php file, then delete the plugin from the admin.

    Because the plugin wasn't activated no settings have been created, so a manual removal wont leave behind any junk at this point.

    Let me know if you have any other questions. ~Chris

  3. Soliduccio
    Posted 4 years ago #

    You have been very accurate, thanks for the answer!

  4. ethanaylett
    Posted 3 years ago #

    Where do you access the "Network Admin" where the plugin can be activated?

  5. tribalNerd
    Plugin Author

    Posted 3 years ago #

    Hello ethanaylett,
    To access the Network Admin you'll need to have your WordPress Network Activated / Multisite Activated feature setup.


    If your WordPress is Network Activated, then you may be logged into a non-super user, which I believe will hide the Network link in the Toolbar.

    Let me know if this helps ~Chris

  6. tribalNerd
    Plugin Author

    Posted 3 years ago #

    Closing this topic, reopen it if the issue still stands.

Topic Closed

This topic has been closed to new replies.

About this Plugin

  • Multisite Robots.txt Manager
  • Frequently Asked Questions
  • Support Threads
  • Reviews

About this Topic