WordPress.org

Support

Support » Plugins and Hacks » Multiple Galleries » [Resolved] [Plugin: Multiple Galleries] Media Library "Show" link not working

[Resolved] [Plugin: Multiple Galleries] Media Library "Show" link not working

Viewing 15 replies - 1 through 15 (of 20 total)
  • Plugin Author Kaspars

    @kasparsd

    This plugin works only with images attached to the gallery of the post. It won’t work on the Media Library tab because it contains pagination and there is no easy way to add and save checkbox selection across paginated sets of photos.

    achensee

    @achensee

    sorry but this issue is NOT resolved!!!

    the problem Justin described occours on any post! Just try to attach an existing image from the media library to a post/page/custom-post-type as an featured image…

    The plugin breaks the “toggle-function” which is used to show/hide the media-panel.

    Kaspars, just set the <table class=”slidetoggle describe startclosed”> to <table class=”slidetoggle describe”>.. it will show you, that the panel exists, but does not open when klicking on the -Textbutton…

    Plugin Author Kaspars

    @kasparsd

    achensee, the plugin is not supposed to work with images from Media Library. It works only with images attached to the specific post.

    achensee

    @achensee

    Kaspars, read my post before. it has nothing to do with the gallery function… the plugin breaks existing jquery function of the media upload panel!

    Correct, this plugin breaks needed core functionality. When plugin is activated, I no longer have the option to add any image into any post via the media library tab, the show link does nothing. This has nothing to do with galleries, or multiple galleries.

    Plugin Author Kaspars

    @kasparsd

    achensee, could you please post the javascript error reported by your browser. Thanks! The more detailed it is, the better.

    achensee

    @achensee

    Kaspar, unfortunately there is no Javascript Error. It’s jQuery! I guess the plugin breaks/renames/whatever the toggle-object or the toggle-function. And I didn’t dig very deep into your plugin by now and cannot say which hook or filter might be the cause for this issue.

    But you should be able to test it for yourself with a WP 3.2.1 install, a theme which uses post-thumbnails (refer to http://justintadlock.com/archives/2009/11/16/everything-you-need-to-know-about-wordpress-2-9s-post-image-feature) and the current version of your plugin. Then try to assign an image from the media library as post-thumbnail…

    orandavis

    @orandavis

    achensee: jQuery is a Javascript library. Check your browser’s console for an error when you toggle to the Media Library tab.

    And I’m pretty darn sure this is the exact same error as in our neighboring thread: cant-add-photos-from-existing-media 🙁
    I think everyone is describing the same problem, only some people describe it differently.

    achensee

    @achensee

    orandavis, thankyou for posting the nieghbour thread – that helps to recognize, that there IS a problem and this issue isn’t resolved yet.

    if you address an object with jQuery but the object doesn’t exist, jQ won’t show up an error necessarily… i suspect the plugin is using a hook or filter which removes the toggle-class or deactivates the jQ toggle function. Other ideas?

    orandavis

    @orandavis

    No problem. 🙂

    Ah, I think I see what you mean there about jQuery. Hmmm.
    Unfortunately my specialty is in PHP, and while I write some jQuery and Javascript, I’m a bit of a beginner. I’ve spent some time poring over the plugin code, but haven’t yet been able to isolate the issue. I posted some info over in the other thread where I tried to track down the problem, but I may have been on the wrong track. I’ll take the insight you’ve kindly provided and have another go at it asap. Will report back with any findings.

    Presently I have kaspars set up with an account on my site where I’m experiencing the problem, but I believe he’s pretty busy and hasn’t had much of a chance to troubleshoot it yet, which I understand. So it’s definitely not a bad idea for us to continue troubleshooting. It is also performing properly for him on other sites, so it would seem that there may be some common thread between the sites having problems that we haven’t dug up yet. Again, I did a pretty thorough rundown of my setup in the other thread so feel free to check that out & perhaps see if anything matches up with your install.

    Thanks,
    Oran

    Plugin Author Kaspars

    @kasparsd

    Thank you all for helping me to debug this! Your effort is much appreciated as I can’t replicate this on my local machine or client websites.

    orandavis

    @orandavis

    You’re very welcome! Please keep us updated! 🙂
    Feel free to troubleshoot on my site. I’m just waiting for a good time to turn it over to my client, so I’m not really actively working on it. Clearly it’s live, but I don’t think there’s much traffic at all (reminds me I should install analytics). If you need to edit the plugin code or anything, go for it, as long as it won’t do any damage to the core installation of course. 😉

    manganesesulfate

    @manganesesulfate

    Tks for sharing !zinc sulfate

    clarklab

    @clarklab

    I’ve got the same problem. We’d just been dealing with it for months until I finally realized that this was the only plugin I was running that touched the media uploader popup.

    achensee

    @achensee

    I think I found a workaround for those of you, who just want to use the ‘post-thumbnail’ function together with a working ‘multiple-gallery’:

    Step 1 – Edit the multiple-galleries.php (found in the plugin directory):

    Search for line 14:
    wp_enqueue_script('multiple-galleries', plugins_url('multiple-galleries/multiple-galleries.js'), array('jquery', 'media-upload', 'utils', 'admin-gallery'));

    Change it to:
    wp_enqueue_script('multiple-galleries', plugins_url('multiple-galleries/multiple-galleries.js'));

    Save the file and upload to your server.
    Note: WP already loads necessary scripts – jquery, etc. is part of the media-upload-popup!

    Step 2 – Edit the multiple-galleries.js (found in the plugin directory):

    Search for line 23:
    w=wpgallery.getWin();

    Change it to:
    w=window.parent;

    Save the file and upload to your server.

    It seems that calling the addt.scripts within the wp_enqueue_script AND calling tinyMCEs getWin() function is causing the problem.

    The workaround doesn’t enable the selection of images for the gallery, which are NOT attached to a post – as Kaspars mentioned: its not easy to build such a function!

Viewing 15 replies - 1 through 15 (of 20 total)
  • The topic ‘[Resolved] [Plugin: Multiple Galleries] Media Library "Show" link not working’ is closed to new replies.
Skip to toolbar