Movable Type Backup Importer
Fatal error: Call to children (line 222) (5 posts)

  1. Fishback
    Posted 4 years ago #

    Performed an MT 4 backup, uploaded unzipped files into designated import folder, setting all to 777. Go the following error. (I replaced my site home directory with xxxxxx.)

    Importing your Movable Type Backup

    Your backup will be processed in chunks if available.

    Importing /home/xxxxxx/public_html/wp-content/blogs.dir/4/files/import/clean-Movable_Type-2011-12-26-19-12-45-Backup-1.xml...
    Fatal error: Call to a member function children() on a non-object in /home/xxxxxx/public_html/wp-content/plugins/movable-type-backup-importer/class-mt-backup-import.php on line 222


  2. Roger Dudler
    Plugin Author

    Posted 4 years ago #

    Hi Fishback, there might be some special (illegal) characters in your XML file. Have you tried to open up the XML file in a browser (e.g. Firefox) to see if it shows some errors?

  3. karlelvis
    Posted 4 years ago #

    I've got that same error.

    When I open my xml file in in a browser, i get:

    This page contains the following errors:
    error on line 6799 at column 155: Encoding error
    Below is a rendering of the page up to the first error.

    Any suggestions?

    I'm trying to get an import that includes tags, the regular importer worked well, but thew away all my tags. I was hopeful that this would get the tags...

  4. acidonitrix
    Posted 4 years ago #

    Hi. Had the same problem, but I managed to have a workaround. Here's how.

    A commenter seeking for help had pasted some weird characters which came from a modem configuration and some protocol feedback.

    That small strings where easily located using firefox to just make the line and column pop out. Weird chars were seen at plain view. I just striped them using a good text editor (notepad++ is good as it is able to handle big files, and has a colored text rendering). The XML then was right.

    Next, I had to chunk the backup into small pieces. I did it by hand. Just keep in every chunk both <movabletype [...]> start and<blog>[....]</blog> block at header. I cut the file being careful not having a tag sliced.

    Then renamed the chunk as the whole original file (I.E: Movable_Type-2012-04-20-18-40-09-Backup.xml), FTPed it, and then process with the plugin. Iterate until you finish with all chunks.

    Done. Having the pretty urls be the same as the old MT, would be fine! :)

    I've been having a look and it seems it works. Hope it helps.


  5. wiredsheep
    Posted 4 years ago #

    I ran into this issue due to non ascii characters in the recovery file. The exporter for some reason stuck them in the file... To fix this I did the following:

    # perl -i.bak -pe 's/[^[:ascii:]]//g' *.xml

    This stripped out all of the non ascii chars from the xml files and the import then worked successfully.

Topic Closed

This topic has been closed to new replies.

About this Plugin

  • Movable Type Backup Importer
  • Frequently Asked Questions
  • Support Threads
  • Reviews

About this Topic