More Taxonomies
[resolved] Slug URL returns an empty archive for a custom taxonomy (5 posts)

  1. jobzesage
    Posted 4 years ago #

    Hi There !

    I'm discovering custom taxonomy, and I'm loving it :-) I want to use it to label some sermons by author and by theme. I used a plugin that creates a cloud of custom taxonomy, and that works. But the link points to a url of the form :


    It returns an empty archive page. Can it be because this taxonomy is used in a custom post type ? Any thoughts ?!?


  2. jobzesage
    Posted 4 years ago #

    Any tip ? I find myself really helpless on this issue...

  3. jobzesage
    Posted 4 years ago #

    I tried this :

    It seems to be the same issue, but using regular tags, not custom taxonomies. That didn't seem to change anything. I saw that in the code provided, there was a conditional checking if it was a category or a tag. I tried to add a condition about my custom taxonomy using the function : is_taxonomy('name') but that returned false no matter what.

    I got curious, so I tried to see all the registered taxonomies with this :

    foreach ($taxonomies as $taxonomy ) {
      echo '<p>'. $taxonomy. '</p>';

    And my custom taxonomies didn't show up ?!?

    Isn't more-taxonomies plugin registering the custom taxonomies ? Any experience on that ?

    Without any help, I might drop the plugin and try to get it done manually... too bad, it really worked smoothly up to this point.

  4. jobzesage
    Posted 4 years ago #

    BTW, I have a public development page now :


    If you click on "Prekner", you'll see my custom taxonomies (by themes and by preacher). If you click on Vekst, a preaching should show up, but it's an empty archive.

    This preaching should be listed :

  5. jobzesage
    Posted 4 years ago #

    OK, finally I figured it out, after many hours of testing and Googling...

    The problem was in theme, the query_posts of my archive.php didn't display custom custom types. I created a file called taxonomy.php, and modified my query post from this :
    to this :

    Now it seems to work perfectly :-)

Topic Closed

This topic has been closed to new replies.

About this Plugin

  • More Taxonomies
  • Frequently Asked Questions
  • Support Threads
  • Reviews

About this Topic