WordPress.org

Support

Support » Plugins and Hacks » More Privacy Options » [Resolved] [Plugin: More Privacy Options] Heads Up for 3.5

[Resolved] [Plugin: More Privacy Options] Heads Up for 3.5

Viewing 5 replies - 1 through 5 (of 5 total)
  • Plugin Author David Sader

    @dsader

    I think it hooks correctly, the necessary “add_actions” seem to still be there on the Settings->Reading page now.

    Yeah, it works – but it’s technically deprecated. For the time being, WP core is just going to show ‘Privacy’ settings on the Reading page, but it spits out an error with WP_DEBUG on and isn’t guaranteed to keep working through future versions.

    Cheers!

    Plugin Author David Sader

    @dsader

    “it spits out an error with WP_DEBUG on”

    I don’t see a debug error in my install.

    <?php do_action('blog_privacy_selector'); ?>

    From options-reading.php… I can’t find a note to blog_privacy_selector as deprecated.

    My mistake, David!

    You’re completely correct (the Warning was coming from a different mu-plugin), and by using blog_privacy_selector rather than the Settings API and putting things in the Privacy settings section, you’ve smoothly survived the upgrade to 3.5. Keep up the good work, and thanks.

    Plugin Author David Sader

    @dsader

    Updated: http://wordpress.org/extend/plugins/more-privacy-options/

    Kick the tires, as you so smartly have done.

    Tanx, Jason.

Viewing 5 replies - 1 through 5 (of 5 total)
  • The topic ‘[Resolved] [Plugin: More Privacy Options] Heads Up for 3.5’ is closed to new replies.
Skip to toolbar