Support » Everything else WordPress » [Plugin: More Fields] Error in 1.3 version

  • Peetboy

    (@peetboy)


    Fatal error: Call to undefined method more_fields_object::rewrite_rules() in /mypath/wordpress/wp-content/plugins/more-fields/more-fields-manage-boxes.php on line 150
    Everytime when i’m inserting custom field I get this error. But finally the field is inserted.
    In the more-fields-manage-boxes.php on lines 150 and 151 are 2 function calls:
    $mf0->rewrite_rules();
    $mf0->flush_rewrite_rules();`
    There is only flush_rewrite_rules() function in the more-fields-object.php. The rewrite_rules() function is missing. Should I comment tha call to function?

Viewing 15 replies - 1 through 15 (of 21 total)
  • jodineuf

    (@jodineuf)

    I am having the same problem.

    teebru

    (@teebru)

    Did either one of you get this to work? I too am having this problem.

    thanks

    musicmasteria

    (@musicmasteria)

    I got the same problem here too. Any ideas?

    Hi Peetboy, jodineuf, teebru and musicmasteria,

    I’m not sure if this is the recommended solution by the plugin developer, but the following worked for me:

    – To resolve the Call to undefined method more_fields_object::rewrite_rules() error, replace $mf0->rewrite_rules(); on line 150 of more-fields-manage-boxes.php with $mf0->generate_rewrite_rules();

    – To resolve the “operand” error when adding fields, replace $wp_rewrite->rules = $new_rule + $wp_rewrite->rules; on line 768 of more-fields-object.php with $wp_rewrite->rules = $new_rule . ' + ' . $wp_rewrite->rules;

    Once again, these solutions worked for me in WordPress 2.8.3. The plugin developers may have better solutions than the above.

    Cheers,
    Matt.

    markgt

    (@markgt)

    great Matt! – works perfectly for me 🙂

    thanks for taking the time to post the fix.

    musicmasteria

    (@musicmasteria)

    It works mattyza! Thanks for the help!

    I hope to plugin author fixes this in the next version.

    Thank you.
    More-fields is a great plugin, but documantation and support (updates and bugs) are somewhat missing….
    I had to touch the core files of that plugin at least 6 times, making hacks and changes with every WP upgrade.
    I guess this is the soft spot on open source plugins, It creates a dependency on the developer ….

    Mattyza, I applied your solution but it breaks the Publish box ( save as draft, status etc). Looks like the ajax thingie wont work anymore, nothing happens when you try to edit the status…I deactivated the modified plugin and the publish box now works again. Anyone experiencing the same problem?

    take this file
    http://exobi.com/jessica/more-fields-object.txt
    and this
    http://exobi.com/jessica/more-fields-object.txt
    and overwrite the original ones from the core. (after backing up of course)

    this bug will be fixed (along with others, and I hope also the permalink problem) in 1.3 that is due soon i think.

    Paul de Wouters

    (@pauldewouters)

    Human Made

    didn’t you make a mistake? you posted the same file twice

    yes .. sorry about that .
    the second file is this :
    http://exobi.com/jessica/more-fields-write-js.txt
    first one is the same :
    http://exobi.com/jessica/more-fields-object.txt

    any idea why my custom fields are being wiped out?

    ive tried the two .txt file updates, but still seems to be wiped out once i edit using more fields, funny thing is its only on apache 2 and php 5.0

    my other server is apache 1.3.x and mysql 5.1 and it works fine.

    those two files should fix the problem (at least on all my installations they did)
    Just to be on the safe side, have you re-named them to *.php ??
    and also, in your screen options, have you enabled 2-columns?

    krembo99, thanks so much for that fix. It works! Fixed the permalink error and a clash with NextGen Gallery. I’m running WP 8.2.4 and More Fields 1.3.

    The only thing i noticed was that the new post type (in my case “Products”) is no longer added to the main admin menu, but thats a small sacrifice to have the plugin working again.

    Thanks again from South Africa 🙂

    I am using this plugin on a bunch of my sites and even though we have to tweak the code with each update. it is a major time saver.

Viewing 15 replies - 1 through 15 (of 21 total)
  • The topic ‘[Plugin: More Fields] Error in 1.3 version’ is closed to new replies.