Support » Plugin: MiniMU » [Plugin: MiniMU] Nesting error in Minimu plugin

  • Resolved WpJoe

    (@wpjoe)


    I’m having this error after activating MiniMu;

    Fatal error: Maximum function nesting level of '100' reached, aborting! in ...\wp-content\plugins\minimu\minimu.class.php on line 2190

    I tried first to add to php.ini file this line;

    xdebug.max_nesting_level = 200

    and then commenting zend_extension line but no luck.

    http://wordpress.org/extend/plugins/minimu/

Viewing 12 replies - 1 through 12 (of 12 total)
  • Plugin Author shelkie

    (@shelkie)

    Hmm – never heard of that occurring with this plugin before. The line number in the error message has to do with the blog list widget. Have you added the widget to your blog? If so, can you try removing it to see if that’s the cause?

    I didn’t add any widget. This happens whenever I try to activate MiniMu plugin.

    Error goes away after deleting this plugin. I just realized that the plugin didn’t update ok. I manually updated to 0.6.3 and with WP 3.3.1 I’m getting nesting error in line 2212;

    $dc_instance=MiniMU::get_instance();

    With all plugins deactivated but MiniMu 0.6.3 and WP 3.3.1;

    Fatal error: Maximum function nesting level of '100' reached, aborting! in ...\wp-content\plugins\minimu\minimu.class.php on line 483

    #483 $arr_return[$key]=MiniMU::get_token('domain_name', $obj_domain->id);

    Plugin Author shelkie

    (@shelkie)

    Could you try disabling xDebug and see if that has any effect?

    Hi Shelkie

    xDebug in my PHP.ini;

    ; XDEBUG Extension
    
    zend_extension = ".../bin/php/php5.3.8/zend_ext/php_xdebug-2.1.2-5.3-vc9-x86_64.dll"
    
    [xdebug]
    xdebug.remote_enable = off
    xdebug.profiler_enable = off
    xdebug.profiler_enable_trigger = off
    xdebug.profiler_output_name = cachegrind.out.%t.%p
    xdebug.profiler_output_dir = ".../tmp"

    When commenting out zend_extension line I get this error;

    The connection was reset
    The connection to the server was reset while the page was loading.

    When commenting out all xdebug lines I go back to the nesting error;

    Fatal error: Maximum function nesting level of '100' reached, aborting! in ...\wp-content\plugins\minimu\minimu.class.php on line 483

    Plugin Author shelkie

    (@shelkie)

    Looks like you’re running WAMP. Could be an issue with the way Apache and PHP on Windows handle the $_SERVER superglobals, which can be different than linux platforms. I’ll try to find some time over the weekend to test this out.

    Cheers,
    Eric.

    Hi Shelkie;

    You’re right 🙂 I was running wamp 2.2a when I tested your plugin.

    WpJoe,

    You need to set a virtual url in your localhost apache to run this plugin properly.

    If you try to run this plugin with an url like “this: http://localhost/testdomain.com”, you´ll get this error.

    Three steps to work:

    1- Allow your virtual domain to loop back to your localhost in the system hosts file (usually in Windows\System32\drivers\etc) by adding these lines:
    127.0.0.1 testdomain.com
    127.0.0.1 sub1.testdomain.com
    127.0.0.1 sub2.testdomain.com
    (and so on, for each subdomain you set in MiniMU)

    2- Create a virtual host in Apache configuration.
    (Usually C:\wamp\bin\apache\Apache2.2.21\conf\httpd.conf)

    Lines to create a virtual host in httpd.conf:

    NameVirtualHost 127.0.0.1:80

    #seta pro localhost
    <VirtualHost 127.0.0.1>
    #ServerAdmin admin@localhost

    DocumentRoot C:\wamp\www
    ServerName localhost
    ServerAlias localhost
    #ErrorLog logs/localhost_error.log
    #CustomLog logs/localhost_access.log common

    </VirtualHost>

    #set testdomain.com
    <VirtualHost 127.0.0.1>
    DocumentRoot C:\wamp\www\testdomain.com
    ServerName testdomain.com
    ServerAlias *.testdomain.com
    <Directory C:\wamp\www\testdomain.com>
    Options All Includes Indexes
    </Directory>
    </VirtualHost>

    3- Set in WordPress General Options (wp-admin/options-general.php):
    WordPress Address (URL) testdomain.com
    Site Address (URL)testdomain.com

    Regenerate permalinks.

    Tip: Replace testdomain.com with url you want.

    Good luck!
    Sandro

    Thanks for your suggestion Daforino 🙂

    I had already set virtual urls in my localhost apache as you described.
    The nesting error appears whenever I try to run Minimu plugin. I don’t have the change of going to the options page. It is activate Minimu-> nesting error screen. Delete Minumu-> error goes away.

    Plugin Author shelkie

    (@shelkie)

    Thanks for posting this Daforino. Helpful for those who must manually configure Apache.

    Have you had any issues using this plugin with WAMP?

    I’d like to know too if somebody is running wamp, wordpress 331 and MiniMu 063 without problems.

    I tried all Minimu old versions and the nesting errors appears since 0.5.8 and above.

    0.4.0 breaks wordpress 331 after clicking “activate” in wp plugins page because the browser goes to wp-admin/… instead of http://yourwordpressfolder/wp-admin/&#8230;

    However, when I went back to wp plugin admin page, Minimu 0.4.0 was running ok and I could reach Minimu options page.

    edit; I tried to set a couple of domains and I rebuilt permalinks but 0.4.0 acts ultra-weird with WP 331. No luck.

    Ok, I have it working now. I did a fresh install of everything; wamp latest version, wp latest version, minimu latest version, no other plugins, default theme, new database. I got rid of the nesting error and I successfully configured several domains.

    I still haven’t caught what was causing this problem. I guess somekind of backwards compatibility with anything I had installed.

Viewing 12 replies - 1 through 12 (of 12 total)
  • The topic ‘[Plugin: MiniMU] Nesting error in Minimu plugin’ is closed to new replies.