Support » Plugin: Related Posts for WordPress » [Plugin: Microkid's Related Posts] New Version causing problems

  • Resolved hauruapai

    (@hauruapai)


    Just upgraded to the latest version and instead of getting the related posts box that will show all of the related posts when words are typed it has disappeared.

    Also a new post that I added (without putting in any related posts) the layout got messed up – there was no “Related Posts None”

    I re-installed an older version and it works again perfectly.

    http://wordpress.org/extend/plugins/microkids-related-posts/

Viewing 11 replies - 1 through 11 (of 11 total)
  • Plugin Author microkid

    (@microkid)

    Hi hauruapai,

    Can you check if you have selected any post types on the plugins settings page?

    And can you explain a little more about how your layout got messed up?

    Oh my God, I thought I was the only one having this trouble. How the layout got messed up? Well, for starters, some of the parts at the end of the post (e.g. ‘Tagged with: blah blah’, ‘File under: blah blah’) which used to be enclosed within the same div box as the post are now outside the enclosing bordered box. And because of this, I have to scroll down to the bottom to see my right sidebar.

    As to the plugin’s interface in the dashboard, it’s unresponsive.

    Right now, I have disabled the plugin. Please help

    (Hey hauruapai, where can I download an older version?)

    Plugin Author microkid

    (@microkid)

    Hi noelmoralde,

    It’s really hard for me to tell what’s going on from the information you give me. Is there somewhere I can see the problem?

    @ noelmoralde
    I always keep backups of old plugins which is why I could upload an older working one. And yes, what you described as a layout mess is exactly what I got to – except you explained it better than me!

    @ microkid
    I went to upgrade the plugin again so I could get screenshots of what is happening for you and seems that the gremlin has moved out of the admin- it now displays properly. I also did a new post and added a related article and it was all good but when I did a new post with no related posts it messed up the layout again

    http://inthetravelworld.com/ is where you can see the post without a related one and messed up layout as well as a post with a related post and no messed up layout

    Now that I see what the new layout in the admin for related posts is I will try and describe what it was like. (It is ok there now)

    There were no tabs for Posts and Pages – instead they were just listed under each other – hyperlinked

    It then said related without the box
    Under that Search Items – A little box and Title Content Both with the buttons

    Then that again. Here is an idea of what it was like:

    —————————————-
    Posts (0)
    Pages (0)
    related
    Search BOX HERE Title Content Both
    related
    Search BOX HERE Title Content Both
    ——————————————

    The only place where there were boxes was where I put BOX HERE above

    For posts that already had related posts it was as follows:

    —————————————-
    Posts (2)
    PostTitle x PostTitle x
    Pages (0)
    related
    Search BOX HERE Title Content Both
    related
    Search BOX HERE Title Content Both
    ——————————————

    Hope this helps πŸ˜€

    Plugin Author microkid

    (@microkid)

    Ah! Now I understand.

    The plugin loads its own CSS file in the admin. This file has been altered in the new version, but your browser was still displaying the old cached version of the file.

    So if you run into this problem, hit shift + refresh or empty your browser cache.

    @noelmoralde does this solve your issue?

    Nope – that has not fixed my sample of the no related posts plugin:

    I hit refresh a few times
    F5 a few times
    Cleared the browser cache

    and still got the messed up layout πŸ™

    Any other ideas? πŸ™‚

    Plugin Author microkid

    (@microkid)

    Ah, I’ve solved the issue. There was an HTML bug that occurred when a post had no related posts and the β€œDisplay this text” option was turned on.

    Please install the new version (3.0.1) and let me know if it works now.

    Perfect – I installed the new one on the site, hit refreshed and all of the messed up payout is fixed πŸ˜€

    Thank you so much for your time and effort – it is truly appreciated πŸ˜€

    Plugin Author microkid

    (@microkid)

    Excellent! Maybe you could take the time to hit the “Works” button in the Compatibility box on the plugins page:

    http://wordpress.org/extend/plugins/microkids-related-posts/

    Wow! It’s back to its glory now. Thanks microkid. I just clicked ‘Works’ back there.

    @hauruapai, thanks for the tip. From now on, I’m saving a copy of all plugins I use.

    @microkid – already did the works when it worked πŸ˜€

    @noelmoralde – glad the tip helped πŸ˜€

Viewing 11 replies - 1 through 11 (of 11 total)
  • The topic ‘[Plugin: Microkid's Related Posts] New Version causing problems’ is closed to new replies.