Meteor Slides
[resolved] One validation error (5 posts)

  1. J. Brown
    Posted 3 years ago #

    Thanks for the great plugin. Tried a bunch of slideshow plugins before meteor and this is, by far, the best. Just one thing, I'm getting a single validation error:

    Error Line 122, Column 59: document type does not allow element "div" here; missing one of "button", "map", "object", "ins", "del", "noscript" start-tag

    <div id="meteor-slideshow" class="meteor-slides navnone">

    The mentioned element is not allowed to appear in the context in which you've placed it; the other mentioned elements are the only ones that are both allowed there and can contain the element mentioned. This might mean that you need a containing element, or possibly that you've forgotten to close a previous element.

    One possible cause for this message is that you have attempted to put a block-level element (such as "<p>" or "<table>") inside an inline element (such as "", "<span>", or "<font>").

    The test page I'm working on is:

    Perhaps I am being a little anal but I just love seeing that green "passed" for all my pages. Maybe someone could hook me up.
    Much obliged.


  2. J. Brown
    Posted 3 years ago #


    Its not your plugin. The error is caused because Wp autop is adding a <p> tag before the short code so the div ends up inside.

    I was able to use this plugin to disable it just on the page I need: http://wordpress.org/extend/plugins/wp-unformatted/

    All green now.

  3. Josh Leuze
    Plugin Author

    Posted 3 years ago #

    If the shortcode is on its own line it shouldn't add in a paragraph, I think the problem might have been some space before the shortcode, or maybe having the text right after it.

    Try using just the shortcode on the first line, then a space, then your content like this, might not need the second plugin:

    <strong>Abhyasa Yoga Center</strong> was founded in 2007 by NY yoga teacher J. Brown. After more than...
  4. J. Brown
    Posted 3 years ago #

    Weird. I disabled the second plugin, removed the custom field to be sure (protocol for WP Unformatted) and when I tried it again that darn <p> tag was gone. No validation errors. Didn't even have to put the line space in. I'm sure it was there before. In any case, I appreciate the reply and not having to have another plugin.

    Thanks a lot.

  5. Josh Leuze
    Plugin Author

    Posted 3 years ago #

    No problem, the WordPress editor can be finicky like that. Like if the visual editor tab is selected when you publish it, a paragraph will be added, but not if you have the HTML editor selected.

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic