Support » Plugin: Meteor Slides » [Plugin: Meteor Slides] Meteor Size

Viewing 8 replies - 1 through 8 (of 8 total)
  • Plugin Author Josh Leuze

    (@jleuze)

    You can change the dimensions of specific slideshows using metadata. Check out this tutorial on slideshows with different sizes.

    Very useful! And nice plugin, Thank you.

    Plugin Author Josh Leuze

    (@jleuze)

    You’re welcome!

    Hi, i followed the steps:
    In the slides settings, set the Slide Height to “750″ and the Slide Width to “700″. Then create a slideshow called “Sites”
    and I add this code in the page:
    [meteor_slideshow slideshow=”Sites” metadata=”height:750, width:700″]

    but the slide images only show 626×200.

    what should i do?
    here is my page: http://www.ecentricdesign.com/portfolio/

    thanks

    SJ

    and I also changed the size to 750×700 in meteor-slides/meteor-slides-plugin.php

    // Adds default values for options on settings page
    	register_activation_hook( __FILE__, 'meteorslides_default_options' );
    	function meteorslides_default_options() {
    		$tmp = get_option( 'meteorslides_options' );
    		if ( ( $tmp['slideshow_quantity']=='' )||( !is_array( $tmp ) ) ) {
    			$arr = array(
    				'slideshow_quantity'   => '5',
    				'slide_height'         => '750',
    				'slide_width'          => '700',
    				'transition_style'     => 'fade',
    				'transition_speed'     => '2',
    				'slide_duration'       => '5',
    				'slideshow_navigation' => 'navnone'
    			);
    			update_option( 'meteorslides_options', $arr );
    		}
    	}

    [Moderator Note: Please post code or markup snippets between backticks or use the code button.]

    but it still doesn’t work

    Plugin Author Josh Leuze

    (@jleuze)

    Hi shengjin, don’t change the settings in the plugin itself, you’ll lose those changes when you update the plugin.

    Do you have more than one slideshow? you only need to follow the instructions in that tutorial if you have multiple slideshows of different sizes. If the slideshows are the same size, you can just set the dimensions in the slideshow settings and leave out the metadata for the size in the shortcode.

    If you do have different sized slideshows and 750×700 is the largest one, you don’t need to set that in the metadata, the slideshow will already be 750×700 by using those dimensions in the settings. You only need to override the dimensions using metadata to create smaller slideshows.

    The slideshow on the portfolio page is currently 750×700, so you can leave out the metadata or plugin hacks, it is only the slide images that are smaller. Most likely, these images were uploaded before the slideshow was set to 750×700. The slide image sizes are generated when the images are uploaded, so try re-uploading the slide images.

    I noticed a couple more issues, you are specifying a slideshow using the slideshow name “Sites”, this can cause conflicts, make sure you use the slideshow slug, probably “sites”, instead:

    [meteor_slideshow slideshow="sites"]

    One other issue, there are code tags wrapped around your slideshow, this can break the layout, switch from the visual to the HTML editor, and make sure that the shortcode is on a line all by itself and that there are no code tags before or after it.

    hi, JLeuze, thank you so much for the detailed message. it works now. you are the best man!

    Plugin Author Josh Leuze

    (@jleuze)

    No problem!

Viewing 8 replies - 1 through 8 (of 8 total)
  • The topic ‘[Plugin: Meteor Slides] Meteor Size’ is closed to new replies.