Metaverse ID
EVE-Online Login (13 posts)

  1. fremeloki
    Posted 5 years ago #


    i tried to use the plugin with eve-online.

    I put under Metaverse ID Admin my EVE-ID and my API Key
    and under Users i added my EVE-ID and use update.

    But...this error comes up.

    Fatal error: Call to undefined function curl_init() in D:\xampp\htdocs\wordpress\wp-content\plugins\metaverse-id\mv-id.php on line 152

    Any help?

  2. signpostmarv
    Plugin Author

    Posted 5 years ago #

    The error message suggests you do not have cURL enabled on your PHP installation; You need to go find the entry for php_curl.dll in your php.ini file and uncomment the line so PHP loads the extension.

    Let me know if this doesn't work :-)

  3. fremeloki
    Posted 5 years ago #

    Okay the error is away. Buuut now the following error came up:

    Problems with MV-ID

    EVE API response is missing required information

    A nonsense error message in my eyes.

  4. signpostmarv
    Plugin Author

    Posted 5 years ago #

    I'll need to go signup for EVE again to debug this fully, shouldn't take too long.

  5. signpostmarv
    Plugin Author

    Posted 5 years ago #

    Well it seems I can't use the API without reactivating my account ($20 seems to be unreasonable to pay to get a bug fixed)

    The reason this error message is being produced is because the name, gender, race or blood line data is missing from the EVE api response. Which is odd, given that the documentation indicates this information should still be present.

    If you go to line 121 in /metaverses/eve.php and add in var_dump($data); you'll be able to see the source code of the API request if you "view source" on the plugin page after trying to cache the EVE profile.

    If the dump doesn't resemble the example in the API documentation (see http://www.eveonline.com/api/doc/data-charsheet.asp ), then there's something funky going on and I'll unfortunately have to remove EVE support from MV-ID until I can afford to spend $20 on a game I'm not playing.

  6. fremeloki
    Posted 5 years ago #

    Thanks for your help.

    I'll try your way and if it doesnt work, i'll create you a new (trail) acc. With a trail account we can test it after 72 hrs.

  7. fremeloki
    Posted 5 years ago #

    Wuah...Im not conform with php. :-)
    I cant see any results....im sorry

    Here is a Trail-Acc for EVE Online.

    Username: testaccforwp
    User ID: 7166008
    API Key: 2E0F5716F1E04881A2263F80A00A928315F8368A961C4C20A12A7413B2A5726B
    Created: 12/10/2010 14:44:43

    Maybe you can help me. :-)

  8. signpostmarv
    Plugin Author

    Posted 5 years ago #

    I've fixed some issues with the EVE plugin, give the latest version a try :-)

  9. fremeloki
    Posted 5 years ago #


    Not working.

    If i enter the trail acc or my acc. The following error came up:

    API Authentication failed, userID paramter was not passed to API

    Now i checked all entries but...no error. Copy & Paste.

    Its right, that i can only enter the USER ID for a new user?

    I entered my User ID and API KEY under Admin but now this error came up:

    Warning: unserialize() expects parameter 1 to be string, array given in D:\xampp\htdocs\wordpress\wp-content\plugins\metaverse-id\mv-id.php on line 963

    Maybe i make something wrong. The right way to enter a new member is:

    1. User (Admin-Panel) -> Metaverse ID
    2. Switch to EVE-Online and enter User-ID
    3. Press Update/Delete
    4. The following user is active.

    Current IDs
    Delete	Update	Metaverse ID	Preview
    		EVE Online
    Shortcode:[mv-id mv='EVE' id='7166008']	Profile is not yet cached.

    5. Under Settings (Admin-Panels) -> Metaverse ID
    6. MV-ID Custom
    7. EVE-Online 1. User ID (for the admin) 2. API-key (from the User ID for the admin)
    8. Ready

    But... still no working.

    Exist an alternative for your modul?

  10. fremeloki
    Posted 5 years ago #

    Commando back!

    I used Version 1.2.2. Now i entered the USER-ID and the following message came up:

    Could not fetch character sheet, character does not belong to account.

    Yep i played with some options and only this error appears.

  11. signpostmarv
    Plugin Author

    Posted 5 years ago #

    Does this error come up when adding your own characters or someone else's ?

  12. fremeloki
    Posted 5 years ago #

    I have my own Char-Infos at admin and the trail acc (or my own) at user.

    Q: It's a http request to the eve server (API-Server) to get the user infos. Right?

  13. signpostmarv
    Plugin Author

    Posted 5 years ago #

    The documentation for the EVE API is available at http://www.eveonline.com/api/doc/data-charsheet.asp

Topic Closed

This topic has been closed to new replies.

About this Plugin

  • Metaverse ID
  • Frequently Asked Questions
  • Support Threads
  • Reviews

About this Topic