Support » Plugins and Hacks » [Plugin: Metaverse ID] curl_setopt_array error

  • Resolved Otenth

    (@otenth)


    Warning: curl_setopt_array() [function.curl-setopt-array]: CURLOPT_FOLLOWLOCATION cannot be activated when in safe_mode or an open_basedir is set in XXXXXXXXXXX/otenth/wp-content/plugins/metaverse-id/metaverses/free-realms.php on line 25

    Warning: curl_setopt_array() [function.curl-setopt-array]: CURLOPT_FOLLOWLOCATION cannot be activated when in safe_mode or an open_basedir is set in XXXXXXXXXXX/wp-content/plugins/metaverse-id/metaverses/metaplace.php on line 24

    These errors are associated with trying to update (cache) Free Realms (line 25) and Metaplace (line 24)

    I have a pretty standard WP install on a hosted LAMP server (vervehosting).

    php 5.2.9
    json support is enabled, ver 1.2.1
    simplexml is enabled, $Revision: 1.151.2.22.2.46 $
    curl is enabled, libcurl/7.19.4 OpenSSL/0.9.8b zlib/1.2.3 libidn/0.6.5

    Any suggestions?

    http://wordpress.org/extend/plugins/metaverse-id/

Viewing 7 replies - 1 through 7 (of 7 total)
  • I’m working on a bugfix. It’ll be in the 0.9.2 release 🙂

    Bugfix has been committed to the server, and has been tested on my local dev box with safe mode turned on.

    Let me know how things go when the update gets pushed out to the plugin directory 🙂

    Better, definitely better! 🙂

    Now I only get this error for Free Realms:

    Warning: curl_setopt_array() [function.curl-setopt-array]: CURLOPT_FOLLOWLOCATION cannot be activated when in safe_mode or an open_basedir is set in /home/kenneth/public_html/otenth/wp-content/plugins/metaverse-id/metaverses/free-realms.php on line 34

    Forgot to check open_basedir as well 😛

    Should be fixed in 0.9.3

    Fixed! Thank you!

    don’t forget to mark the topic as resolved! 😛

    First time I’ve ever created one of these. I didn’t even think to do that. Thanks for the reminder!

Viewing 7 replies - 1 through 7 (of 7 total)
  • The topic ‘[Plugin: Metaverse ID] curl_setopt_array error’ is closed to new replies.