Support » Plugin: Meta Tag Manager » [Plugin: Meta Tag Manager] NOT WORKING – Description Meta Tag Content

  • I’ve just added the meta tag description to our site and set it to appear on the front page. When I refresh the site and go to the homepage, the meta description tag is still empty: GlossArts.com

Viewing 5 replies - 1 through 5 (of 5 total)
  • Plugin Author Marcus

    (@netweblogic)

    NetWebLogic Support

    what was the tag? I do see an MTM description tag with the following:

    Classical Music Concerts, Ballet, Modern Dance, Opera, Culture & Arts Events Calendar from Gloss Arts Magazine

    If you have caching plugins of some sort, try purging the cache.

    Thanks for the quick reply Marcus. Looking at the source, it looks like there are two meta descriptions tags. One at the top of the page and one further down with the correct content. Aren’t these conflicting? I’d imagine that the first tag is what search engines will see and that one is empty.

    Plugin Author Marcus

    (@netweblogic)

    NetWebLogic Support

    I was only looking for the ones generated by meta tag manager, which will always appear between these lines in the source:

    <!-- Meta Tag Manager -->
    ...
    <!-- / Meta Tag Manager -->
    

    I don’t see that now, so I’m assuming it’s deactivated. The description you currently see isn’t generated by us, probably by your theme or another plugin. We don’t remove other meta tags or check for duplicates, we just add/edit our own ones.

    No, I have not deactivated it and the <!– Meta Tag Manager –> tag is still in place with the correct content. I think the issue lies in the fact that the plug-in does not replace the primary description tag which is what is read first when your page loads. (I have no other meta tag plug ins)

    I guess I could manually remove the default tag. Do you know what file your plugin updates as I don’t see it in the header.php?

    Plugin Author Marcus

    (@netweblogic)

    NetWebLogic Support

    we don’t update any files, that’s why we can’t/don’t replace other meta tags.

    I do still see the tag from MTM actually, maybe I missed it last time.

    However, if it’s still there, and the plugin is deactivated, then you have caching on your site which hasn’t been purged. I’m 100% certain of that, and looking again at your source at the bottom it says this:

    <!– Cache served by Simple Cache – Last modified: Sat, 11 Feb 2017 19:07:30 GMT –>

Viewing 5 replies - 1 through 5 (of 5 total)
  • You must be logged in to reply to this topic.