WordPress.org

Support

Support » Plugins and Hacks » Meta Tag Manager » [Plugin: Meta Tag Manager] Deprecated usage

[Plugin: Meta Tag Manager] Deprecated usage

  • krbvroc1

    @krbvroc1

    Turning on WP-DEBUG yields warning messages due to this plugin:

    ‘Notice: has_cap was called with an argument that is deprecated since version 2.0! Usage of user levels by plugins and themes is deprecated. Use roles and capabilities instead.’

    The problem is line 32:

    add_options_page() uses the deprecated hard coded capability of the number 8. That should probably be replaced with ‘manage_options’.

    When you get a chance can you make this small change and update so WP_DEBUG does not complain?

    Thanks.

    http://wordpress.org/extend/plugins/meta-tag-manager/

Viewing 1 replies (of 1 total)
  • krbvroc1

    @krbvroc1

    Another problem is the the deprecated usage of wp specialchars.

    On line 44 and 45, you should change to:

    $name = esc_html ( $meta [0] );
    $content = esc_html ( $meta [1] );

    That will get rid of a bunch of DEBUG warnings.

Viewing 1 replies (of 1 total)
  • The topic ‘[Plugin: Meta Tag Manager] Deprecated usage’ is closed to new replies.
Skip to toolbar