Support » Plugins and Hacks » [Resolved] [Plugin: Mendeley Plugin] Visual Interface

[Resolved] [Plugin: Mendeley Plugin] Visual Interface

  • Hi,

    I am working on a wordpress site using the Mendeley plug-in. The API key and the collection IDs have all been worked out. I then made a folder of papers that I wanted to display on the website.

    When I enter [mendeley type=”folders” id=”######” ] unfortunately all I get is some raw code or sometimes nothing at all. Is there a graphic interface? Do I need to create one myself? I think I may have missed a step.

    Many Thanks!


Viewing 7 replies - 1 through 7 (of 7 total)
  • Plugin Author kochm


    When you are using this shortcode on one of your WordPress pages, you should either get a formatted list of the paper references (in HTML) or an error message (also in HTML/ASCII).

    If you provide me with the URL of your page, I can have a quick look.

    Here is the link: https://press.ci.uchicago.edu/ianfoster/pubs/

    Hopefully you can see what my problem is?

    Plugin Author kochm


    Yes I can. The current problem is that you have switched “debugging” on. Go to the configuration page of the plugin and select “no” in the section “Debug” and press “Update settings” – Then the output should go away and the normal output should be visible.

    Unfortunately when I turn off “Debug” I get a blank page. Its confusing because the code that is on the page, when I am using the “Debug” setting, doesn’t seem to suggest that anything is wrong.

    Plugin Author kochm


    Okay. I see. There seems to be an error in producing the output – since the plugin does not only generate no output, but terminate the generation of the page.

    Can you please share the document (reference) / the folder that is causing the problem with me, so I can try replicate the problem on my system?

    I am using a folder with a collection ID # 14222433. At this point there is only one article in that folder. The title of the article is “Globus Online: Accelerating and Democratizing Science through Cloud-Based Services”.

    Thanks for your help!

    Plugin Author kochm


    Since folders are private I cannot access your folder 14222433. But I did generate an own folder an put the document “Globus Online” in it. Then I used [mendeley type=”folders” id=”14786033″] on one of my pages – and everything worked – i.e. the reference was displayed.

    So, the problem must be specific to your WordPress/PHP setup. Perhaps some version issues? Can you please check the PHP and Web-Server error logs if calling the plugin / displaying the page with the mendeley shortcode does generate any error messages?

Viewing 7 replies - 1 through 7 (of 7 total)
  • The topic ‘[Resolved] [Plugin: Mendeley Plugin] Visual Interface’ is closed to new replies.