[resolved] Can't Select a Custom Role Member from Edit Post (8 posts)

  1. dragonblogger
    Posted 4 years ago #

    Have an issue with Members plugin where some of my staff send Word docs to me and I create posts on their behalf, so I am logged in as administrator, click on Edit Post, but when I try to select the "author" of the post, the authors I have defined in a "custom role" created by Members do not show up in the authors list, yet all my regular contributors and editors do.

    They exist because the author can log in, create posts, submit them for review, I just can't select them from the author drop down in WordPress in the Post Editor. (Maybe because WordPress doesn't know how to query the custom role to show authors?).

    Is there any way around this?


  2. lozkane
    Posted 4 years ago #

    I have the same issue. Some users appear, others do not. I have tried changing user to author, editor, but still not appearing.

    This appear to be a bug

  3. dragonblogger
    Posted 4 years ago #

    It is a bug, hoping the plugin developer can look into it.

  4. Justin Tadlock
    WordPress God
    Plugin Author

    Posted 4 years ago #

    This is not a plugin issue. It's a WordPress bug. See:

  5. dragonblogger
    Posted 4 years ago #

    Thanks Justin, wow bug opened for 15 months with no progress. Is there a work around, I don't mind editing my core WordPress files if it is simply changing a function.

  6. Justin Tadlock
    WordPress God
    Plugin Author

    Posted 4 years ago #

    The workaround is in the replies to that ticket, specifically:

  7. Thomas Maier
    Posted 4 years ago #

    I just ran into exactly the same problem and had a look at the ressources mentioned here. Unfortunately, I don't know where to put this.

    I just added the following to my themes functions.php, without the effect of seeing my custom roles in the author select box.

    $role = get_role( 'myrole' );
    $role->add_cap( 'level_1' );

    Any specific advice? Thanks

  8. Scott
    Posted 3 years ago #

    Hey Justin,
    I've tried adding the 'level_1' capability but it didn't take. Any other ideas?

Topic Closed

This topic has been closed to new replies.

About this Plugin

  • Members
  • Frequently Asked Questions
  • Support Threads
  • Reviews

About this Topic