WordPress.org

Support

Support » Plugins and Hacks » Media Tags » [Plugin: Media Tags] Some visual aid tags being applied fix

[Plugin: Media Tags] Some visual aid tags being applied fix

  • In Media Manager, when applying Media Tags in bulk to a greater amount of images (e.g. 200), there is a considerable latency before seeing any feedback at all, like a page reload wheel (FF5). This sets doubts if something’s happening or if we have clicked the submit button at all. For this reason, adding some feedback that Media-Tags is currently working would be useful. I’ve achieved this while disabling the bulk panel when clicking submit:

    media-tags/js/mediatags_bulk_library.js li ~57:

    if (button_name != "")
    	dialog_buttons[button_name] = function() {
    		//[alx359] Some visual aid when bulk tags are being applied
    		//mediatags_process_bulk_selections('library')
    		jQuery(this).addClass('ui-state-disabled');
    		if (!mediatags_process_bulk_selections('library'))
    			jQuery(this).removeClass('ui-state-disabled');
    	}

    media-tags/js/mediatags_bulk_common.js ~li 129, right before the last closing bracket:

    //[alx359] added. To manage enable/disable submit button
      return true;
    }

    EDIT1: added code to not disable the panel if any error

    EDIT2: A better solution would be to disable both buttons themselves. One still can hit ‘Cancel’ on a (long) running task, but it still continues to happen in the background, and finally reloads the Media Manager. That could produce some undesired effects.

  • The topic ‘[Plugin: Media Tags] Some visual aid tags being applied fix’ is closed to new replies.
Skip to toolbar