Support » Plugin: Media Tags » [Plugin: Media Tags] not able to attach media to page

  • After installing the media tags plugin, I am unable to attach a media file to a page from the media library screen. When I search for a specific page in the Attach dialog box, it returns “No posts found.” Attaching the media to a post still works, but not when I try to attach to a page. Also, attaching a file from the “Edit Page” screen works correctly, but attaching a file from the media library screen does not.

    I understand that media tags is a more powerful way to manage these attachments, but I need the ability to attach to a page due to the way the theme was set up. Is there a fix for this issue?

    Thanks for your time.

    http://wordpress.org/extend/plugins/media-tags/

Viewing 6 replies - 1 through 6 (of 6 total)
  • Plugin Author Paul Menard

    (@pmenard)

    The attachment of media item to Posts or Pages is not a function of Media-Tags. This is something in WordPress.

    What Media-Tags does is allow you to ‘tag’ media items just like you would tag a Post item.

    On my development system running WordPress 3.1 RC3 and latest version of Media-Tags I can upload a media item into the Media Library. Then click the ‘Attach’ link within the Media > Library. I see the popup titled ‘Find Posts or Pages’. I enter just ‘a’ into the search input field. Then select the ‘Pages’ radio button. Then click ‘Search’. I receive a list of Pages in my system.

    I click the radio button beside the row item in the list. Then click the ‘Select’ in the lower right of the popup. The popup closes and the Media Library listing refreshes. Now the media item is associated with that selected page.

    pmenard, thank you for your time. I appreciate your feedback but I still am convinced that there is an issue with media tags. This plugin is the only plugin I have installed, and when I deactivate the plugin the attach dialog box works correctly. I have also tried changing themes to see if that was the cause.

    When I do a large-scope search for a term like “e”, I get a list of posts for either a post search or page search. In other words, clicking the Page radio button has the same effect as clicking the Post radio button.

    Hope this helps.

    Plugin Author Paul Menard

    (@pmenard)

    Hmm. Well since it works for me in WP 3.1 RC3 there might be some differences in WP 3.0.2. I’ll check this.

    Plugin Author Paul Menard

    (@pmenard)

    jc364

    Yeah, I can confirm this is not working. And can confirm your statement this is something involving Media-Tags since when I disable the plugin the search does seem to work. In my first reply when I was searching under Pages it does return a listing. But that list is wrong since I only have the default About page.

    Will run more development test and provide an update.

    Thanks for brining this up to my attention.

    Thanks for your response!

    By the way, I love the plugin. It was just what I was looking for.

    Plugin Author Paul Menard

    (@pmenard)

    jc364

    One other thought in case you really need to use the Assign popup. In the Media-Tags Settings you can turn off the Bulk admin option for the Media Library. This seems to allow the Library Assign popup to work.

Viewing 6 replies - 1 through 6 (of 6 total)
  • The topic ‘[Plugin: Media Tags] not able to attach media to page’ is closed to new replies.