Support » Plugin: Media Tags » [Plugin: Media-tags] Fatal error when attempting to activate plugin

  • When I try to activate the Media Tags plugin I get the following:

    “Plugin could not be activated because it triggered a fatal error.”

    That’s not much to go on.

    Thing is, I have a development version of my website and I have the same plugins installed there and for some reason on that site I’m able to activate the plugin with no problem…

    Are there any known conflicts/issues that would cause this issue and not allow the plugin to be activated?

    Thanks,

    Vic

Viewing 7 replies - 1 through 7 (of 7 total)
  • Plugin Author Paul Menard

    (@pmenard)

    Thanks for the comment. Fatal Error? Mind pasting into this thread the exact message from the PHP Fatal Error? If it is not displaying then you should open your site’s wp-config.php file and change define(‘WP_DEBUG’, false); to define(‘WP_DEBUG’, true); then retry.

    Known conflicts? Yes and No. Really depends on which other plugins you have loaded. You mentioned you were able to activate on your development site. Is the dev and Fatal Errors sites EXACTLY the same as far as plugin, theme, configurations?

    Give me more information and I can help narrow down the issue.

    Thanks.

    Here’s what I got:

    Plugin could not be activated because it triggered a fatal error.

    Notice: Undefined index: HTTPS in /home/screenra/public_html/wp-content/plugins/bits-on-the-run/bitsontherun.php on line 12

    Nothing directly related to media tags, but could the item above be the issue?

    Thanks!

    Vic

    The problem turned out to be this according to my super-awesome developer:

    the problem is on lines 118 and 119 of media-tags.php, i have commented it out now:
    include_once ( dirname (_FILE_) . ‘/mediatags_legacy_convert.php’ );
    mediatags_plugin_version_check();

    looks like something to add backward compatibility

    Of course now I have another where /media-tags/slug is generating a 404.

    Sigh.

    Plugin Author Paul Menard

    (@pmenard)

    You are correct. The include statement and call are used to convert from the older style (pre-Custom Taxonomy) logic used in version 1.0 of Media-Tags.

    I’m not seeing how this include and function call will cause a fatal error. No less an error being reported in another plugin file. Strange setup on your end?

    I have a LOT of plugins on my site. My developer ended up being able to get the plugin installed by deactivating all other plugins and reactivating them. However I still have a problem where they /media-tags/slug/ URLs are very twitchy. Today I tried to change media-tags to galleries and ended up with the 404 error once again.

    I really LOVE the functionality of this plugin, but I’m very concerned with having something so seemingly delicate driving what I hope to be a core function of my site.

    Vic

    Plugin Author Paul Menard

    (@pmenard)

    I really have no idea why your setup is causing issues with the plugin. There are literally thousands of other users who love the plugin and have not reported issues. Maybe there is a conflict with some of the other used plugins. I’m not sure. And I’m still not sure on the fatal error you reported. Again, this is not something I can investigate since every user’s website is unique.

    As for the 404s this is not really delicate in that it uses standard WordPress core functionality to register the custom taxonomy for the tags.

    At this point if you are having such issues then please feel free to try a different solution.

Viewing 7 replies - 1 through 7 (of 7 total)
  • The topic ‘[Plugin: Media-tags] Fatal error when attempting to activate plugin’ is closed to new replies.