WordPress.org

Forums

[Plugin: Media Tags] 2.2.7 causes mediatags.php template page to break (5 posts)

  1. kingkong954
    Member
    Posted 5 years ago #

    I upgraded to 2.2.7 from 2.2.6 and at first everything seemed fine.

    Then some days later one of my users made some changes to the media tags (deleted a tag and moved some images over to another tag). After they were done, they came running because the media tag pages looked busted.

    It seemed as though my mediatags.php template was no longer being used.

    That's the thing that makes /media-tags/exampletag/ , and lets me make a customized/archive view. It seemed to be falling back onto my default template.

    Once I downgraded to 2.2.6 everything went back to normal.

    I tried a few things like clearing caches, re-saving permalink settings, and even de/re-activating the plugin, but nothing worked.

    Any thoughts?

    http://wordpress.org/extend/plugins/media-tags/

  2. Paul Menard
    Member
    Posted 5 years ago #

    @kingkong954 sorry for the delay on answering this. I'm the author of the Media Tags plugin. I'll start investigating. The version 2.2.7 did have some code cleanup that might have affected the template section. I'll check and let you know. Would you be willing to test out a best version of the changes? Wold be better to make sure before I post an update the wordpress.org and have it wrong again.

  3. Paul Menard
    Member
    Posted 5 years ago #

    @kingkong954 Yeah there is something wrong here. In 2.2.5 the template file gets called properly. But for some reason in 2.2.7 (not sure what happened to 2.2.6) the template is not called. Thanks for bring this up to my attention. Working on a fix. Hope to have it out soon.

  4. kingkong954
    Member
    Posted 5 years ago #

    Thanks Paul!

    We've updated the plugin version to the latest. If anything freaks out, I will be sure to let you know.

    Thank you for all of the hard work you've done making this really amazing plugin.

    I saw you reference in another post that the new 3.0 tax. setup might put an end to you managing this plugin? Have their new core functions basically integrated what you've done here?

  5. Paul Menard
    Member
    Posted 5 years ago #

    @kingkong954

    Thanks. Yeah just updated Media-Tags 2.2.8. Should fix your issue with the template.

    As to the WP 3.0 comments. There are a few threads I've seen on the official WP blogs about possible 3.x enhancements. Since 3.0 (actually 2.9.x) allows for custom Taxonomies the thought is you may not need Media-Tags specifically but be able to roll your own.

    This has happened already once. I wrote a plugin called Revisions which allow for versioning of the Post/Page content. Six months after I released the plugin WP came out with versioning built-in. And they used some of the plugin code in code. Maybe I should go to work for WordPress.

Topic Closed

This topic has been closed to new replies.

About this Topic

Tags