Support » Plugin: Media Library Assistant » [Plugin: Media Library Assistant] [mla_gallery] working only for the author

  • Resolved mll



    I’ve made a post which contains :

    [mla_gallery tag=”Logo-candidat” size=”medium” orderby=”title” link=”file”]

    I was reported that my post features no image at all, while actually the gallery displays on my screen 11 images !

    Well, I could see thet if I disconnect from wordpress, they’re right : I see no image at all. Nothing related to any gallery in the HTML source either. Very strange !

    PM me if you need a sample URL.

Viewing 9 replies - 1 through 9 (of 9 total)
  • Plugin Author David Lingren


    How strange! I just made a test post with a similar [mla_gallery] and could not reproduce your problem. The gallery shows up whether I’m logged in or not.

    Please give me a sample URL and any other information you think might help.

    The best way to help me look into this would be to send me some screen shots of the problem(s), e.g., the MLA listing page with the images that should appear and the HTML view of the post/page content where the [mla_gallery] shortcode is used. If you’re willing to do that or you have other information you don’t want to post here, go to the Our Story/Contact Us ( page at and give me your e-mail address. I’ll send you my e-mail address and we can exchange more information.

    Thanks again for using the Media Library Assistant and for your patience while I work on this issue.

    Plugin Author David Lingren


    Thanks for working with me on investigating this problem and for access to your site. My testing has not revealed any issues with the [mla_gallery] shortcode itself, but that some other plugin, theme or module is adding a WHERE clause to the SQL statement issued for the query. This additional SQL logic is limiting the search to items “attached” to the current post/page.

    I have the list of plugins your site is using and I will continue my investigation to find where the additional SQL clause is coming from.

    Thank you Daniel

    Well’, I’m quite puzzled, because now it works. The only thing I remeber is I upgraded to MLA v0.60.

    Well, anyway, I’m marking this thread as resolved. đŸ™‚

    Plugin Author David Lingren


    Thank you for this update.

    As we’ve discussed by e-mail, I have found that the Role Scoper plugin is modifying the SQL WHERE clause of every database query that includes post_type = 'attachment'. This is causing some of the [mla_gallery] queries to fail for any Media Library item not “attached” to the post or page containing the [mla_gallery].

    There is nothing in the .60 release that solves this issue, and I do not know why it seems to be working for you now; it still fails for me in my test setup. I will keep working on a fix for this issue that works for everyone, all the time.

    I will leave this issue “resolved” for now, since it is not a defect in the Media Library Assistant itself.

    Oh, so I know why it works now : when you did some testing on my website, you did attach some media files to a post. So yes, I guess it would still fail for unattached media while using Role Scoper.

    Plugin Author David Lingren


    Yes, that’s what I thought until you showed me the other post that included the [mla_gallery]. Maybe Role Scoper does not care which post an image is attached to, just that it’s attached to something…

    I just did another test and it’s true! Once you attach the image to anything it gets through the Role Scoper logic, even for posts and pages that are not the parent. How colorful!

    Plugin Author David Lingren


    I have released version 0.71 which contains a fix for the Role Scoper interaction. Please give it a try and let me know if you have any further problems.

    Thanks for your patience and for using the plugin!

    It does work !! Thanks a lot Daniel, what a support ! đŸ™‚

Viewing 9 replies - 1 through 9 (of 9 total)
  • The topic ‘[Plugin: Media Library Assistant] [mla_gallery] working only for the author’ is closed to new replies.