Support » Plugins and Hacks » Plugin meant to work with Amazon RSS feed links?

Plugin meant to work with Amazon RSS feed links?

Viewing 15 replies - 1 through 15 (of 15 total)
  • Plugin Author PeteWilliams


    Hi, it looks like one of the plugin files has been deleted. This URL is now returning a 404 error: http://www.startdetoxingtoday.com/wp-content/plugins/amazon-affiliate-link-localizer/ajax.php

    Try removing and reinstalling the plugin and let me know what happens.



    Deleted and reinstalled, the URL still returns a 404

    Plugin Author PeteWilliams


    Hmm, is the file definitely there on your server? Browse to that directory in an FTP program to check. If so, do you have a .htaccess file on your server? That could be setting some URL redirects that are stopping this script from being accessible. Try disabling it and try again.


    I’ll get back to you on that. I had someone create the site for me and the hosting was transferred to me, he took care of moving over all the WordPress files with access to my cpanel. Will need to check with him as I’m not sure how to do it myself.

    Thanks for your help

    Plugin Author PeteWilliams


    OK. Good luck and please let me know what you find out.

    The site developer is very puzzled by this one. It’s actually working for some people and updating the links with the tags, but for myself and two other people I have asked to test it they are not.

    Still can’t get this sorted. When you look at the site I assume you do not see the tags either? The developer said he removed the database completely and added it back. They have tested on several different machines and IP addresses and they say they see the tags, however I have checked several on my end and not seen them.

    Sorry for the excessive posting but I just found out that Amazon search results are working but still not product links. Can see this here – http://www.startdetoxingtoday.com/the-3-day-detox-diet-plan-what-it-entails/ at the bottom of the post, the first link changes to my uk ID and Amazon UK, but the second link doesn’t. (For both tests I used the link with my US ID)

    Plugin Author PeteWilliams


    Hi, the problem still seems to be with the ajax file which returns a 404:

    The search link works because it doesn’t require the ajax file, the other one does.

    Did you check for a .htaccess file and trying with it disabled? I still think that’s the likely problem.


    Thanks for getting back, I’ll check again. When following that link, what should be displayed instead of a 404?

    I looked at the file myself

    # BEGIN WordPress
    <IfModule mod_rewrite.c>
    RewriteEngine On
    RewriteBase /
    RewriteRule ^index\.php$ – [L]
    RewriteCond %{REQUEST_FILENAME} !-f
    RewriteCond %{REQUEST_FILENAME} !-d
    RewriteRule . /index.php [L]

    # END WordPress

    That’s what’s in the .htaccess file. Anything there look wrong to you?

    Plugin Author PeteWilliams


    Well for the above link it should display:

    arrLinksToCheck[ ‘B002PD41PK’ ].localiseLink();

    Try deactivating the .htaccess file (rename it) for a second and then reloading the link and see if it works then you’ll know if it’s the problem.

    No luck, tried the link and still get the 404 and checked the links in the RSS feed just to make sure as well and no change. Such a weird issue!

    Plugin Author PeteWilliams


    Hmm, did you definitely deactivate the htaccess file? How did you do it? I’m pretty sure it’s some form of redirect causing the problem, and if it’s not htaccess then I’m kind of out of ideas to be honest. I think there are other ways redirects could have been set up on the server, but that’s where my knowledge runs dry I’m afraid.

    I went to the file manager in cpanel and went to the startdetoxingtoday.com file and found .htaccess, i right clicked and selected rename and called it ‘htas’.

    It’s just very weird that all my other sites work perfectly that are on the same hosting :/

    Thanks for your help though!

Viewing 15 replies - 1 through 15 (of 15 total)
  • The topic ‘Plugin meant to work with Amazon RSS feed links?’ is closed to new replies.