WordPress.org

Support

Support » Plugins and Hacks » Markdown for P2 » [Resolved] [Plugin: Markdown for P2] Cannot disable markdown parsing

[Resolved] [Plugin: Markdown for P2] Cannot disable markdown parsing

  • Something very weird is happening on my P2 install after having tried this plugin.

    I find myself unable to turn off markdown parsing!

    What I did is: I tried both “Markdown on Save” and “Markdown for P2”, to see which one worked better for me.

    Then suddenly, I noticed that I could not see the raw markdown version anymore when editing. After hitting “publish”, I would always see the full HTML, even in the edit window.

    This worried me, so I disabled and deleted both extensions: this didn’t help, any markdown is still auto-converted into html.

    In addition to that, the syntax isn’t transformed correctly.

    # Something like this should give a H1 header

    but it’s transformed into:

    <ol>
    <li>an ordered list</li>
    </ol>

    So I’m not sure if the problem is directly related with your plugin, or with “Markdown on Save”, but basically my usage of markdown is pretty much broken now 🙁

    http://wordpress.org/extend/plugins/markdown-for-p2/

Viewing 2 replies - 1 through 2 (of 2 total)
  • To give some more detail:

    If I re-install and activate your plugin, everything is working fine, markdown gets parsed correctly (the above code becomes H1), and during editing I can see the raw markdown syntax.

    As soon as I disable your plugin, I have the problem described above. Pretty weird. But at least the plugin works…

    Ok, now I finally understand where the confusion came from. My impression that the plugin continued to parse my posts even after being disabled came from P2 itself – this theme has a few markdown-like parsing functions built-in!

    Here is the official information:
    http://p2guide.wordpress.com/2012/04/26/writing-ordered-lists-numbered/

    So the # in the beginning of the line being transformed into a numbered list is the normal way of P2 parsing.

Viewing 2 replies - 1 through 2 (of 2 total)
  • The topic ‘[Resolved] [Plugin: Markdown for P2] Cannot disable markdown parsing’ is closed to new replies.
Skip to toolbar