Support » Plugin: MapPress Maps for WordPress » [Plugin: MapPress Easy Google Maps] Mappress not displaying properly in TABS

  • Resolved Mimmmi

    (@mimmmi)


    Hi there
    I am getting a problem where i am trying to display the map in a tab, but only a small piece of the actual map is displayed in the top left corner.. the rest is greyed out. if i reload or refresh the page however, the entire map displays correctly. i do not want my users to have to refresh the page to see the map correclty.

    I did change my stylesheet for my tabs to visibility:hidden, as suggested by a post in a ‘resolved topic’ but this does not seem to have helped.

    Any help would be appreciated

    http://wordpress.org/extend/plugins/mappress-google-maps-for-wordpress/

Viewing 8 replies - 1 through 8 (of 8 total)
  • Hi,
    Unfortunately, I don’t have solutions and I have the same problem. I use wordpress post tabs. I just give nice helpers some precisions, found with firebug, about the problem :
    As says Mimmmi, “map is displayed in the top left corner” and I add that map is not displayed in good position (the left and top style of the “divs” are wrong). If I reload the page, I see the map but always in wrong positions.

    So, I suppose that a change of CSS is not enough… So, Mimmmi, have you found a solution ?…

    thanks for (nice) helpers.

    yes, I’ve got it !!!

    change your css “display:none” to “visibility:hidden” AND add for the hidden tabs :

    height:0;
    padding:0;
    margin:0;

    In my case, if I only change “visibility:hidden” the visible tab looks like empty but… It was just down !

    Hi yacks,

    could you be more precise, where do I need to make which changes ?

    Is it only in the “post tabs” files ?
    Where exactly ?

    Thanks

    Andree

    Hi Andree,
    You just change your css file, depend on your style posttabs you choose. In my case, I add to style.css in wordpress-post-tabs/css/styles/default/ that :

    .ui-tabs .ui-tabs-hide {
    height: 0;
    margin: 0;
    padding: 0;
    visibility: hidden !important;
    }

    the line “visibility:hidden” replace the original line “display:none”

    I hope that helps you (with my english so…)
    Yacks

    Thanks, now I got it I am using a different plugin:

    http://wordpress.org/extend/plugins/posttabs/

    Anyway thanks

    Andree

    Hey! andree2005!
    Have you fixed this issue with http://wordpress.org/extend/plugins/posttabs/ plugin?

    Hi,

    yes I could solve that, simply go to

    -> Settings -> postTabs

    Go to: Links behavior / Single Post or page

    and choose “Permalink” instead of “Hide-Show Tabs”

    Hope that helps.

    Andree

    Yes, Ok.
    I know about the “Permalink” options and have already set it in my WP.
    I thought that you`ve found another way to solve this issue.
    Anyway thanks for your answer…
    Best regards,
    Vitaliy

Viewing 8 replies - 1 through 8 (of 8 total)
  • The topic ‘[Plugin: MapPress Easy Google Maps] Mappress not displaying properly in TABS’ is closed to new replies.