WordPress.org

Forums

MapPress Easy Google Maps
[resolved] After WP 3.2.1 Update, Errors (6 posts)

  1. alygirl1969
    Member
    Posted 3 years ago #

    After updating WordPress to version 3.2.1, I get these errors:

    Main Page Map

    Warning: Invalid argument supplied for foreach() in /home/alysonfl/public_html/wandercast.tv/wp-content/plugins/mappress-google-maps-for-wordpress/pro/mappress_pro.php on line 318

    Internal Maps

    Fatal error: __clone method called on non-object in /home/alysonfl/public_html/wandercast.tv/wp-content/plugins/mappress-google-maps-for-wordpress/pro/mappress_pro.php on line 302

    http://wordpress.org/extend/plugins/mappress-google-maps-for-wordpress/

  2. alygirl1969
    Member
    Posted 3 years ago #

    Also, not able to update MapPress Easy Google Maps to version 2.38, because I get this error:
    An error occurred while updating MapPress Easy Google Maps: Update package not available..

  3. alygirl1969
    Member
    Posted 3 years ago #

    I tried a manual upload, overwriting all the files in the map-press folder and went to my website. When I reloaded the page, I got this error:

    Fatal error: Class 'MapPress_Pro_Settings' not found in /home/alysonfl/public_html/wandercast.tv/wp-content/plugins/mappress-google-maps-for-wordpress/mappress.php on line 51

  4. chrisvrichardson
    Member
    Plugin Author

    Posted 3 years ago #

    Hi,

    Please go to my forum and provide:
    - A url to your blog
    - Your PHP version
    - The plugin version you're trying to install

    http://wphostreviews.com/forums

    From what you've written above it looks like it's not installed properly. That can happen if you try to upgrade the Pro version from the free (wordpress.org) version. You need to download the Pro version from my site, not from wordpress.org.

    You might want to double-check that you've got a clean install.
    1. Deactivate the plugin
    2. Delete the entire plugin directory
    3. Now extract the Pro version of the plugin to the WordPress plugins directory. Make *sure* it's the Pro version you downloaded from my site.
    4. Activate the plugin

  5. alygirl1969
    Member
    Posted 3 years ago #

    Is this your site to purchase the Pro version? From the way I am using MapPress, do I need the developer version?
    http://wphostreviews.com/purchase?product_id=4233

    URL to my blog:
    http://www.wandercast.tv

    PHP version:
    5.2.15

    Plugin version:
    from 2.30 to 2.38

  6. chrisvrichardson
    Member
    Plugin Author

    Posted 3 years ago #

    Hi,

    Please move further post to my forums, it makes it easier for me to help you out:
    http://wphostreviews.com/forums

    I think the problem is that Pro version is being overwritten with the free version when you're trying to upgrade. You'll need to download the latest Pro version and install it (that's the correct link).

    Thanks!
    -Chris

Topic Closed

This topic has been closed to new replies.

About this Plugin

  • MapPress Easy Google Maps
  • Frequently Asked Questions
  • Support Threads
  • Reviews

About this Topic