Maintenance Mode
Error on Multisite (6 posts)

  1. Silvan Hagen
    Posted 4 years ago #

    Environment Info
    I'm using a WordPress network installation on my server and the awesome Domain Mapping plugin. We are releasing new magazines every second month. The Maintenance Mode Plugin is installed on all sites in the network, but the maintenance mode is only used on the blogs that aren't yet released to the public.

    Problem description
    When not logged in to the site or the network, I now see the following php error instead of the maintenance site by the plugin. This happens only on the blogs in my network where the plugin is set to maintenance mode "on":

    Fatal error: Call to undefined function is_rtl() in /home/myserver/public_html/wp-includes/general-template.php on line 2102

    Any suggestions or ideas? It worked fine before WordPress 3.3.


  2. ialima7
    Posted 4 years ago #

    Same situation. Same error.

    Fatal error: Call to undefined function is_rtl() in /home/myfolder/wp-includes/general-template.php on line 2102

  3. Silvan Hagen
    Posted 4 years ago #

    It's very strange, but there are several plugins out there causing the error including the very popular and not free plugin http://www.popupdomination.com/live/ according to what I've found on the web.

    Still couldn't couldn't get it working again.

  4. Roger Coathup
    Posted 4 years ago #

    The problem is on single site installs as well.

  5. Riddergraniet
    Posted 4 years ago #

    Yes I have the same issue on a single site install as well. Any idea as for a solution? Is this a WP Maintenance mode plugin problem? Can we solve it?

  6. Nickolabs
    Posted 4 years ago #

    This seems to only occurs when I use the "Use 503 file in theme" options.

    If I was to use the default maintenance mode templates, it works.

    Edit: Upon further debugging, I found out the two lines that were breaking the two things for me:

    wp_admin_css( 'login', true );
    wp_admin_css( 'colors-fresh', true );

    I commented those out, which broke my style. Then, I simply went to the wp-login file of my server, and grabbed those two lines:

    <link rel='stylesheet' id='wp-admin-css'  href='http://nickolabs.com/wp-admin/css/wp-admin.css?ver=20111208' type='text/css' media='all' />
    <link rel='stylesheet' id='colors-fresh-css'  href='http://nickolabs.com/wp-admin/css/colors-fresh.css?ver=20111206' type='text/css' media='all' />

    and placed those CSS link instead of the wp_admin_css calls.

    My layout isn't quite the best anymore, still got a few issue with CSS priorities, but adding a few !important statement might do it.
    That is, until they fix that broken plugin.

    Hope that helps!

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic