WordPress.org

Support

Support » Plugins and Hacks » [Plugin: MailPress] upgrade failed

[Plugin: MailPress] upgrade failed

  • Attempted to upgrade via plugins page and got the following

    Incompatible archive: PCLZIP_ERR_BAD_FORMAT (-10) : Invalid archive structure

    Plugin upgrade Failed

Viewing 11 replies - 1 through 11 (of 11 total)
  • I’m getting the same thing.

    I do not think you can use the automatic upgrade feature for this plugin, due to the fact that there are multiple folders in the archive.

    I too have to upgrade my mailpress, but am planning on doing it this way:

    1. deactivate all the mailpress plugins
    2. delete them via ftp
    3. unzip folders I want from plugin package
    4. upload the specific modules I want
    5. Activate the modules one at a time

    I have not tested this yet, but hope it works…

    ~ Dave

    I am seeing the same error for every plugin I attempt to upgrade through the wordpress admin. I am able to manually upgrade plugins through cPanel file manager by uploading the zip and then extracting the files, but if I try the automatic upgrade I get the error:

    Incompatible archive: PCLZIP_ERR_BAD_FORMAT (-10) : Invalid archive structure

    I updated my Wp from 2.7.1 to 2.8 and started getting this error too. I cant auto update my plugins.

    I got the same error with every attempt to upgrade plugins and when I try to upgrade to 2.8

    Same here… Was able to upgrade to 2.8 via the auto upgrade; but after that I have not been able to autoupdate anything else and receive the same error as the OP.

    Same here, upgraded to 2.8 and am getting the same error message when trying to upgrade plugins.

    Same things happen with me – I’m going to restore to the old version

    Found a fix in this thread http://wordpress.org/support/topic/278487?replies=26
    You need to load a new version of http.php to your wp-includes folder. It’s a simple download from that post.

    In my case deactivating the core control plugin solved all my woes

    with mailpress, do not use automatic upgrade.

    see readme.txt of last release

    new release: MailPress 4.0.1
    new documentation : http://www.mailpress.org
    a forum : http://groups.google.com/group/mailpress

Viewing 11 replies - 1 through 11 (of 11 total)
  • The topic ‘[Plugin: MailPress] upgrade failed’ is closed to new replies.
Skip to toolbar