[resolved] [Plugin: MailPress] TinyMCE problems? (4 posts)

  1. lorr
    Posted 6 years ago #

    Hi there!

    First of all: it's a mighty good plugin! Thanks, arena!

    Now, my problem: I installed and set up this plugin relatively fast so everything's working but the visual editor.

    When I want to write a new mail the visual editor appears briefly then disappars. And that's all. I can use the plain text editor but hey, wth.

    I tried in many browsers - same results. I tried to figure out any possible plugin conflict - same results.

    So... any idea? Anybody? Thank you very much in advance!

    (WordPress 2.8.6 + MailPress 4.0.2)


    Posted 6 years ago #

    if (class_exists('MailPress') && !class_exists('MailPress_fix_TinyMCE') && (is_admin()) )
    Plugin Name: MailPress_fix_TinyMCE
    Description: Fix TinyMCE with Viper Video Quicktags and Cforms
    Author: Amaury Balmer, Andre Renaut
    Author URI: http://www.herewithme.fr
    add_action( 'init', 'MailPress_fix_TinyMCE', 999 );
    function MailPress_fix_TinyMCE() {
    	if ( (MailPress::get_page() != MailPress_page_write) || (MailPress::get_page() != MailPress_page_edit) )
    	// Viper video quicktags
    	global $VipersVideoQuicktags; 
    	$Viper_mce_buttons = ( 1 == $VipersVideoQuicktags->settings['tinymceline'] ) ? 'mce_buttons' : 'mce_buttons_' . $VipersVideoQuicktags->settings['tinymceline'];
    	remove_filter( $Viper_mce_buttons, 		array(&$VipersVideoQuicktags, 'mce_buttons') );
    	remove_filter( 'mce_external_plugins', 	array(&$VipersVideoQuicktags, 'mce_external_plugins') );
    	remove_filter( 'tiny_mce_version', 		array(&$VipersVideoQuicktags, 'tiny_mce_version') );
    	remove_action( 'edit_form_advanced', 	array(&$VipersVideoQuicktags, 'AddQuicktagsAndFunctions') );
    	remove_action( 'edit_page_form', 		array(&$VipersVideoQuicktags, 'AddQuicktagsAndFunctions') );
    	// Cforms
    	remove_filter( 'mce_buttons', 		'cforms_button');
    	remove_filter( 'mce_external_plugins', 	'cforms_plugin');
  3. lorr
    Posted 6 years ago #

    Hi Arena,

    it works perfectly! Thank you very much! :)

    I have another question though so I will open another thread ('cause it is successfully solved). :)


  4. masterbassie
    Posted 5 years ago #

    i'm still having problems with this... i noticed under version 5.0 that it was missing "?>" at the end of the fix_TinyMCE file.

    however this did not fix it - any suggestions? it is (most likely) a cforms problem given it works with it disabled.

Topic Closed

This topic has been closed to new replies.

About this Topic