WordPress.org

Support

Support » Plugins and Hacks » [Resolved] [Plugin: MailChimp Widget] Issue setting up: Do not sufficient permissions to access this page.

[Resolved] [Plugin: MailChimp Widget] Issue setting up: Do not sufficient permissions to access this page.

Viewing 11 replies - 1 through 11 (of 11 total)
  • Plugin Author jameslafferty

    @jameslafferty

    Hi marketingbloxx,

    Which version of the plugin are you using?

    Best regards,

    James

    Finally found out what was wrong. the “…make your changes here” link doesn’t work. But, if you go to plugins and click on edit then it lets you put in the api and then it worked. So, I would either fix that link to the word “here” or put in directions about how to edit it.

    Plugin Author jameslafferty

    @jameslafferty

    Hi marketingbloxx,

    I’m glad you got your issue resolved, but I’m still unable to reproduce the problem. Could you tell me which version of the plugin you’re using, on which version of WordPress? I’d like to get it fixed, but can’t without more information.

    Best regards,

    James

    Hi, i have the newest version of wordpress 3.1.3 and I have version 0.8.6 of the plugin.
    Safari Browser…WooThemes- Gazette Theme.
    Here’s what I did.
    Downloaded plugin
    zipped it on imac
    uploaded plugin
    activated plugin
    then the line appeared at the top of the page that said “you’ll need to setup the mail chimp signup widget plugin options before using it. You can make your changes “here”. When I clicked on “here”, it said not sufficient permissions”.

    It actually said “not sufficient permissions” in more than one place. I clicked on it from somewhere else and it said the same thing.

    Plugin Author jameslafferty

    @jameslafferty

    Yes… all those links should be to the same location. What was the url they were linking to for you?

    It also seems really odd that going to Plugins >> Edit would help. There’s another link to the admin panel for the plugin under Settings >> MailChimp Widget in the left sidebar… maybe that’s the link that worked for you?

    Best regards,
    James

    Plugin Author jameslafferty

    @jameslafferty

    Hi marketingbloxx,

    Have you had any success in resolving your issue?

    Best regards,

    James

    Hey James

    I am also having the same issue. I get the message “You’ll need to set up the MailChimp signup widget plugin options before using it”. You can make your changes here. But on clicking HERE, the link goes nowhere. Looking at the url when i hover over the link, I realise that it is pointing to the same page that I am currently on, hence why the link stays on the same page.

    The link points to mysite/wp-admin/options-general.php?page=mailchimp-widget/lib/ns_mc_plugin.class.php (the link in the widget area points to the same place)

    I also tried replacing the end of the url with mcapi.class.php in the browser, it takes me to a page which says i do not have sufficient permissions to access.

    I am using version 1.2.4 with WP 3.2.1 (it says its compatible up to 3.1.4 but some ppl said that they got it to work with 3.2 soo..)… Hope this clarifies the problem.

    So, I will try putting in the API the way the user above suggested.

    sorry.. version 0.8.7

    Plugin Author jameslafferty

    @jameslafferty

    Hi Mimmmi,

    Could you tell me a bit more about your setup? In particular, are you using a single site install or multisite? Also, could you tell me a bit about your permalink structure? This issue has seemed to have been resolved (and I remember coding a fix for it) in most environments, so this is likely something new that I’d like to get to the bottom of. 🙂

    Thanks so much,

    James

    hi James
    I am using a single site install with permalink structure /%postname%

Viewing 11 replies - 1 through 11 (of 11 total)
  • The topic ‘[Resolved] [Plugin: MailChimp Widget] Issue setting up: Do not sufficient permissions to access this page.’ is closed to new replies.