Support » Plugin: MailChimp List Subscribe Form » [Plugin: MailChimp List Subscribe Form] redirect URL for "thank you" page not working

  • Hello,
    I recently signed up for Mailchimp and installed the widget on my website

    Everything within the plugin works amazingly except for one thing. Upon entering your email, name, and hitting submit, you do not get redirected to the URL that I have put into the Mailchimp website. The widget’s message comes up and tells the user to confirm their email, but it does not redirect the user to the URL that I have specified.

    Please help, and thanks in advance for everything!

Viewing 7 replies - 1 through 7 (of 7 total)
  • It looks like the website is currently using the embedded form instead of the plugin, and it is redirecting properly. Did you switch the forms out after posting this message, or were you seeing the issue with the embedded form originally?

    If you prefer using the plugin, disabling JavaScript in the WordPress settings page should make the redirect work properly.

    And if you want to stick with the embedded form, we recommend disabling the MailChimp plugin as it is adding extra information to the web page which is not needed by the embedded form.

    Eep eep!

    I would rather use the plugin and disable the javascript, as long as it doesn’t affect any other important factors on my site…would the adsense ads still show if the javascript was disabled?

    Plugin Author mc_nate


    Hey there!

    Just to clarify, the WordPress plugin will use the in-line validation. The only way to get the “Thank You” page would be to use the embedded form. The WordPress form will use inline validation and bypass the “Thank You” page entirely.

    However, disabling the javascript in the embedded form will not affect any other part of your website, at all. We’ll only disable the javascript for that embedded form! 🙂

    Let us know if we can help with anything else!


    Hi, I’m using the embedded form code on this site, but the subscription confirmation page doesn’t come up when someone clicks subscribe.

    It does WORK — people ARE being added to the list and they DO receive the click here to confirm your email subscription, but it doesn’t LOOK like anything is happening so it’s not good.

    I tried using the widget but that wouldn’t work either.

    On this site, there are other MailChimp plugins running. I tried turning a few of them off, still have ChimpExpress running too.

    Any tips?

    Plugin Author mc_nate


    Hey there, Jenn!

    What we’d recommend doing is generating the embedded form and disabling javascript. That will create a popup (or you could set it to the same window if you want to modify the code) of the “Thank You” page that’s set up within your MailChimp account.

    To disable javascript, you’ll want to generate a new embedded form and go to “options”. From there, check the box that says “disable all javascript”:

    Screenshot —

    Let us know if we can assist with anything else! We’re happy to help!


    Thank you! This looks like exactly what I need to do.

    But, I can’t figure out how find the Options tab that you’re showing. I’m just not familiar enough with MailChimp yet. If I’m on the lists page and click on forms for the list I want, I see the form I’ve already created but no obvious way to make a new form, delete this old one, or access the lovely options menu you’ve shown me in your screenshot.

    I’m sure I’m just missing something.

    Can you point me in the right direction?

    Much appreciated.

    Plugin Author mc_nate


    Sure thing!

    First you’ll go to “Lists” -> “Forms” —

    Then go to “share it” -> “Create Form HTML” —

    And from there, go to “Classic Form” -> “Options” —

    You can also refer to our quick Knowledge Base article, here:

    How can I add my signup form on my website?:

    Let us know if we can help any further. 🙂


Viewing 7 replies - 1 through 7 (of 7 total)
  • The topic ‘[Plugin: MailChimp List Subscribe Form] redirect URL for "thank you" page not working’ is closed to new replies.