WordPress.org

Support

Support » Plugins and Hacks » MailChimp List Subscribe Form » [Plugin: MailChimp List Subscribe Form] MailChimp Setup not showing in WP 3 Network / Multisite mode

[Plugin: MailChimp List Subscribe Form] MailChimp Setup not showing in WP 3 Network / Multisite mode

  • Hi Guys,

    First off – Love MailChimp and love the plugin. Great work!

    Just one little quibble, I’m running a WP 3 network and it seems that only super admins can see the MailChimp Setup item under the settings menu. This means that individual users must provide the network admin with their API key and list details in order to get the plugin working.

    Do you plan on changing this behaviour?

    I’m not sure on the preferred approach but I notice that WordPress Stats places a config item under the ‘plugin’ menu when in network mode. This seems like a good solution because it means that if network admins have granted the right to add / view plugins users are also able to see the options.

    Cheers,

    – D

    http://wordpress.org/extend/plugins/mailchimp/

Viewing 4 replies - 1 through 4 (of 4 total)
  • We’ll keep it in mind, but it’s probably going to be pretty low on the list.

    birniescott

    @birniescott

    Hi guys,
    Totally agree with the first comment above, great plugin. I changed from Campaign Monitor (which I believe has been discontinued now..?) over to MailChimp.
    Having just installed, activated, integrated into a footer widget and successfully have it adding subscribers to my MailChimp lists. I have now tried to add the same widget to another site on my Multisite detup but it is not working. It asks for the API key which I have also added and it redirects the widget plugin to the other multisite? Meaning it does not setup properly.
    Is this plugin capable of working on multisite? Has anyone managed to get it working on a multisite setup?

    Hope someone can help as I thought I had found the perfect email signup solution.

    Thanks

    daneglerum

    @daneglerum

    birniescott,

    The plugin works fine for me in a multisite setup, however it needs to be setup and activated by a super admin for each site.

    Are you wanting to have multiple sites all subscribe to the same list or is each site, and it’s list, independent?

    birniescott

    @birniescott

    Hi

    I am the super admin and I am trying to install the plugin on both of my two sites. Different mailing lists for different sites. I have generated different list ids, api ids are the same and also client ids are the same.
    The problem is that when it I go to enter the Id in the other site on pressing the submit button it jumps back to the other website? This seems strange to me? I have mailchimp working on it at the moment in an old school form format so the client can start collecting subscribers.

    Can you confirm if you are using multiple sites with different lists?

Viewing 4 replies - 1 through 4 (of 4 total)
  • The topic ‘[Plugin: MailChimp List Subscribe Form] MailChimp Setup not showing in WP 3 Network / Multisite mode’ is closed to new replies.
Skip to toolbar