WordPress.org

Support

Support » Plugins and Hacks » [Plugin: MailChimp List Subscribe Form] Mail Lists dropdown empty after API entered

[Plugin: MailChimp List Subscribe Form] Mail Lists dropdown empty after API entered

  • Hi there,

    I just downloaded and activated the mailchimp plugin. When I go to the Mailchimp settings page, I enter my correct API key (verified) and the “Mailchimp Lists” dropdown displays, except there are NO LISTS populated.

    1) yes my API is associated with 3 lists
    2) when I use the same API with “Autochimp” those three lists are correctly displayed
    3) because the dropdown box is empty I can never setup the signup form

    How do I get the lists displaying?

    Cheers,

Viewing 15 replies - 1 through 15 (of 23 total)
  • Follow the steps here and we’ll go from there.

    Ok, there are no entries under the API key section, says “Goose egg” and I tried to connect last night. So, I’m assuming that means that outbound http is being blocked.

    I just sent an email to the server admin to see what the firewall is doing.

    I’ll post here when I hear back from him.

    Thanks for your help so far!

    Doh, I forgot that section was there and is misleading. Check farther down under the “Last 24 hours of API calls” table

    :))

    first entry.
    ——–
    12/14/2010 08:27am

    nope 68.151.0.239 lists php 0.047s MCAPI/1.3 1.3

    further down
    ———–
    12/14/2010 08:19am

    nope 68.151.0.239 getAccountDetails php 0.018s MCAPI/1.3 1.3

    what does it all mean! 😛

    the mystery continues.

    Hi mc_jesse,

    I posted under the other thread by accident, sorry!

    So talked with the server admin, he’s been working to get ftp working due to an issue between active and passive mode. He assures me that if there was an issue with outbound http traffic you wouldn’t see any web pages. Perhaps I misunderstood your comment on the other thread.

    Please let me know if there is a way forward or at least other places to check for this problem. I absolutely need to get mailchimp working ASAP.

    thanks!

    Ok, I just hit the mailchimp plugin settings page, and then immediately checked the mailchimp.com “24 hour section”, and I got this:

    12/15/2010 10:35pm (green check mark)

    nope 68.151.0.239 lists php 0.043s MCAPI/1.3 1.3

    Thanks.

    Ok, then I need the follow-up info requested from the other thread:

    If so, post your username for me (or a the “u” parameter from the signup form we host).

    username: ecoevolver
    u=d5db283f7841dcd7811fc15c9&id=372409a809

    OK folks, this was happening to me, and I’ve found the culprit. It may or may not help you.

    I also had the ‘AutoChimp’ plugin installed. I just disabled it and the MailChimp plugin now works properly.

    Regards,

    Phil.

    @boldbelvoir,
    That isn’t really a solution because they are both needed in order to fully maximize the mailchimp services. Without Autochimp there is no integration of users between WP and MC. Not to mention the loss of automailer when you publish a new blog post.

    @mc_jesse
    Any progress or suggestions yet?

    Cheers,

    Yes, I realise it isn’t a solution. Just reporting the cause, as it seemed that no-one knew…

    Please let me know if you find a solution.

    @boldbelvoir,
    Autochimp’s latest version is the real culprit. I just went back to the version 0.82 and everything is working just fine.

    Haven’t figured out the real problem though.

    hhmm, how do you grab that version @anujbhartiya? I’d try that out.

    thanks

    Ok I just deleted the v1 and installed v0.83 and the problem has gone. Guess we’ll have to wait for a fix. Thanks for your help.

Viewing 15 replies - 1 through 15 (of 23 total)
  • The topic ‘[Plugin: MailChimp List Subscribe Form] Mail Lists dropdown empty after API entered’ is closed to new replies.