WordPress.org

Forums

MailChimp List Subscribe Form
[resolved] Disable Preferred Fomat options (6 posts)

  1. just2izy
    Member
    Posted 3 years ago #

    Mailchimp Plugin 1.2.5

    How do I disable the preferred format options in the widget?

    http://wordpress.org/extend/plugins/mailchimp/

  2. mc_nate
    Member
    Posted 3 years ago #

    Hey there!

    Within the plugin, there's not a way to disable JUST that portion of the signup form. What we do is look at the form that's hosted over in your MailChimp account and bring over those settings.

    However, with that said, there is a neat little trick that you can do to hide those settings in the plugin and have them displayed on your list (if you want to keep them there). What you'll want to do is open up your MailChimp list and then go to "Settings" -> "list name and defaults" and from there, disable the option for email type preference.

    Screenshot: http://cl.ly/2n1A021N3m1d3u2h0y2t

    After that has been disabled and saved within your list, you'll want to go back to your WordPress dashboard and go to "Settings" -> "MailChimp Setup" and then click on "Update List". This will update the settings in your WordPress plugin and remove that option for HTML, text, or mobile options.

    If you'd like to re-add the options to your form that's hosted on MailChimp, you can go back to the list's settings and re-enable that feature. Because the plugin doesn't communicate automatically with your MailChimp list, those options won't be added back to your WP setup until you click "update list" again.

    It's kind of a workaround and not nearly as complicated as I've made it seem. ;)

    If we can help with anything else, give us a shout!

    Cheers

  3. just2izy
    Member
    Posted 3 years ago #

    It is actually not complicated at all, but I have disabled the plugin forf now due to the Settings issue it is causing and used the embed code.

    Will keep this workaround in mind for future ref.

    Thanks

  4. mc_nate
    Member
    Posted 3 years ago #

    No problem!

    If you're looking for an immediate solution to that issue, a fellow WordPress-user came up with a fix, here:

    http://wordpress.org/support/topic/mailchimp-plugin-v125-settings-corruption?replies=29

    Alternatively, you could always use our embedded form, as well:

    How can I add my signup form on my website?: http://eepurl.com/gOGN

    As always, if we can help with anything else, give us a shout. :)

    Cheers

  5. Trebuchet_mag
    Member
    Posted 3 years ago #

    Hi there, I've changed the settings.

    "After that has been disabled and saved within your list, you'll want to go back to your WordPress dashboard and go to "Settings" -> "MailChimp Setup" and then click on "Update List". This will update the settings in your WordPress plugin and remove that option for HTML, text, or mobile options."

    But can't seem to follow these instructions. :(
    As from dashboard I can't see the 'settings' button.

  6. mc_nate
    Member
    Posted 3 years ago #

    Hey again!

    In order to get to your MailChimp plugin, you'll want to log into your WordPress dashboard and in the left column the "Settings" option should be in the left hand column, towards the bottom. From the "Settings" menu, you should see a "MailChimp Setup" option. Click on that and you should get something that looks like this:

    Screenshot -- http://cl.ly/image/2s2Q031r0t2e

    Cheers

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic

Tags