WordPress.org

Forums

  1. dsaro
    Member
    Posted 3 years ago #

    I am trying to add CSS ids to my style sheet and it is not working properly. Some of the elements work, but not the others.
    When I check with the inspection tool, it takes me to MailChimp style sheet, which I do not even see in Editor.
    Need to update the elements in my stylesheet.

    http://wordpress.org/extend/plugins/mailchimp/

  2. mc_nate
    Member
    Posted 3 years ago #

    Hey there, Dsaro!

    What specifically seems to be giving you problems? Any changes to the styles should be made in your "Style.css" file under "Appearance" -> "Editor" -> "Style.css" for your theme. Using the built-in inspection tool for Chrome or "Firebug" for Firefox, you can isolate exactly what elements need to be added and edited in that CSS file.

    For example, to edit the "Submit" button, right click on it with Chrome and then use "Inspect Element":

    http://cl.ly/3Y2b0b0C3R412Z2Q3x2W

    You'd then need to add input#mc_signup_submit.button to your stylesheet.

    Let us know if you're having some specific issues and we'll be happy to help!

    Cheers

  3. Rosencruez
    Member
    Posted 2 years ago #

    I think what dsaro is referring to is the mailchimp css that is auto-included when the signup form. The one that shows up when I open up Chrome developer tools or Firebug is http://www.example.com/?mcsf_action=main_css&ver=3.3.2

    So for example, if I was trying to change .mc_signup_submit to have the property of text-align: left in style.css, the mailchimp CSS would overwrite that rule with its default text-align: center

  4. mc_nate
    Member
    Posted 2 years ago #

    Hey there!

    Generally we would recommend disabling the "Custom Styling" option within the settings for the plugin ("MailChimp Setup"). That should pull any styling for the Style.css file rather than the included CSS:

    Screenshot -- http://cl.ly/image/1k1Q2K1M3B0S

    Cheers!

  5. Tim
    Member
    Posted 2 years ago #

    Hi mc_nate.

    I've turned the custom CSS styling off, so the widget keeps most of the style for the other widgets (title etc).

    However, I want to do two things:
    1) turn off the "* = required field" line
    2) turn off the "Preferred Format" list of radio buttons.

    I just want the email and name fields, and the subscribe button.

    The obvious way to do this is "display: none;" in css, but it's not working when I put it into the theme style.css. Where should it go?

    I've put
    #mc-indicates-required {
    display: none;
    }

    into the theme's style.css, but it's not appearing at the frontend (being over-ridden?)

    Thanks
    Tim

  6. mc_nate
    Member
    Posted 2 years ago #

    Hey there, Tim!

    Would you mind sending a link to your site so I can have a closer look?

    As far as the "Preferred Format" option, I do have a nifty little hack-around that should let you disable that option within the plugin. Check out this post:

    http://wordpress.org/support/topic/plugin-mailchimp-list-subscribe-form-disable-preferred-fomat-options?replies=6

    I'll be happy to take a closer look at the site, too!

    Cheers

  7. darrenhead
    Member
    Posted 2 years ago #

    Hi,

    I am having problems disabling the "Custom Styling" within the plugin. I untick the checkbox and use my styling with wordpress' "style.css" but for some reason the MailChimp css is still be displayed. Can anyone help at all on this?

    Cheers,
    Darren

  8. mc_nate
    Member
    Posted 2 years ago #

    Hey Darren,

    Can you shoot me a link to your site to have a closer look at things?

    Cheers

Topic Closed

This topic has been closed to new replies.

About this Plugin

  • MailChimp List Subscribe Form
  • Frequently Asked Questions
  • Support Threads
  • Reviews

About this Topic

Tags