Support » Plugins and Hacks » [Plugin: Magic Fields] All line breaks stripped from multi-line fields

[Plugin: Magic Fields] All line breaks stripped from multi-line fields

Viewing 3 replies - 1 through 3 (of 3 total)
  • I have created a Magic Fields version with an integrated Markdown editor (http://markitup.jaysalvat.com/examples/markdown/) as an additional option when setting up custom write panels.

    This replacement text editor repairs the currently bug-ridden integration of the TinyMCE editor in Magic Fields i.e. all paragraphs and line breaks are preserved with this editor.

    The Markdown editor also offers an easy syntax for writing HTML, i.e. a “#” before the Title will create a <h1>Headline</h1>, but also the menu icons can be used to add the markup. For H2 headlines use “##” etc, it`s a very easy to learn syntax, try out the syntax on this sample page: http://markitup.jaysalvat.com/examples/markdown/

    Additionally you can paste text from MS Word or any other text editor without having to worry that pasted style attributes will mess up your text in WordPress (which is a BIG problem with the WordPress default TinyMCE editor).

    Also you can paste/write HTML directly into the Markdown editor. HTML will be recognised as such and not altered.

    More information here:

    Oks i tried to replicate this bug and i can’t do it

    In which operative system are you running magic fields? in apache or on IIS? what is the name of your custom field, which browser you are using for see the bug?

    I need be able to replicate the bug for fix it.

    Hi Gnuget, thanks for your reply.

    The site is running on an Apache server. WordPress version 2.9.1. Since I am building a multilingual site I use also the Qtranslate plugin, not sure if this is important.

    The line break issues appears with multi-line fields (with TinyMCE editor), which have a lot of other bugs too i.e. switching between visual view and HTML view will erase all formatting, generally formatting is VERY buggy, almost not to handle i.e. creating a headline or similar. When selecting text the cursor seems to shift sometimes too.
    Generally full new paragraphs and line breaks are not preserved (or only once, but after the next saving of a multi-line field all formatting is gone).

    Also I can not even deactivate the visual editor from the Magic Fields settings, since then my whole page stays gray and nothing is loaded (WordPress admin area for pages/posts).

    I use Safari 4 and Firefox 3.6 equally for development (under Mac), it did not make a difference to the line-break problem.

Viewing 3 replies - 1 through 3 (of 3 total)
  • The topic ‘[Plugin: Magic Fields] All line breaks stripped from multi-line fields’ is closed to new replies.