Support » Plugins » [Plugin: Magic Fields] Add New button doesnt work properly

  • I have installed magic fields and have been using it successfully for a while now but I have noticed one problem that id like to fix. I’ve looked for a solution but I cant find any so im hoping someone can help me here.

    When adding a post in wordpress, theres a button saying “Add New” which when clicked, will let you add a new post easily. However when im adding a post with magic fields in a custom write panel, the “Add New” button goes to the standard wordpress add post page.

    However, if i edit the post, the add new button does exactly what I want it to do and it takes me to the add post for the custom field that im in.

    To make more sense, i have made a screenshot showing more details. Heres the screenshot.

    Screenshot Here!

    Any help would be really appreciated and ill even throw over a little donation if anyone can help me.

    Kind Regards,

    Adam.

    P.S – I understand the problem but im not so advanced at php to fix this. Ive tried copying code from edit.php to post-new.php and post.php but it didnt work so i really need someone that will help me with the coding rather than just telling me what the problem is as I already have a slight understanding of the issue, i just cant fix it 🙁

Viewing 2 replies - 1 through 2 (of 2 total)
  • Having the exact same problem. Did you find an answer?

    sheriffderek

    (@sheriffderek)

    not glad to hear that their is no answer for this yet… but glad to know i’m not the only one. it’s hard to tell a client… “just make sure every time you want to put up a news story – you can’t press ADD NEW – you’ll have to go to news>manage>add new.” really messes up what is supposed to be so CMS about it.

    magic fields 2 was just releases a while back. i think that it addresses the problem by getting rid of custom write panels and changing to custom post type. it seemed to be working like “magic” when i set up adminimize and tested everything… client side UI was perfect. however… when i went to write posts… and pressed update… none of my info stayed in the fields. just goes blank. but i think that it is a problem on my end.

    i recomend you try magic fields 2 for your next NEW project… because it’s not backwards compatible…

Viewing 2 replies - 1 through 2 (of 2 total)
  • The topic ‘[Plugin: Magic Fields] Add New button doesnt work properly’ is closed to new replies.